summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-15 12:55:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-15 17:21:18 +0100
commit1b7cb6e5e8bd4cab8f607339ac1d73c37c03f929 (patch)
tree05b5600e80770c24a466819d9666142b7724615a /kde-frameworks/prison
parentkde-frameworks/oxygen-icons: 5.113.0 version bump (diff)
downloadgentoo-1b7cb6e5e8bd4cab8f607339ac1d73c37c03f929.tar.gz
gentoo-1b7cb6e5e8bd4cab8f607339ac1d73c37c03f929.tar.bz2
gentoo-1b7cb6e5e8bd4cab8f607339ac1d73c37c03f929.zip
kde-frameworks/prison: 5.113.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/prison')
-rw-r--r--kde-frameworks/prison/Manifest1
-rw-r--r--kde-frameworks/prison/prison-5.113.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/kde-frameworks/prison/Manifest b/kde-frameworks/prison/Manifest
index 650e83c3433a..56e9377c78ad 100644
--- a/kde-frameworks/prison/Manifest
+++ b/kde-frameworks/prison/Manifest
@@ -1 +1,2 @@
DIST prison-5.112.0.tar.xz 55284 BLAKE2B c2039140b77af23e0b8d0d7fef4e41e8fc1a0fb0f10bd6162ba562129aef7c7942d67b432c6fdbbb015bb8256b2525821793202619d1756cea3f0bd8a09ef967 SHA512 ada3f82ea4dd3b8c3bc9a0c4c6768c4d40a60844da4ce1ca9e0c58ae72a11a39b93902b7372384b919e5bc8f0c274c4e21bc2eaf2f56a1e31a845e62bb2ef558
+DIST prison-5.113.0.tar.xz 55268 BLAKE2B bb40ba1c406c31945439abeb71ec74e14a1b8a37026c7fe7973bd96d4ca9924b3b32b3a1e28b38bc36f595fe14b4b46dd0d350d64676a14a0745e5df7b36d892 SHA512 9c83824cdf0c2fa0c3a2584124b47af575f65ad17f4317bb94edeb60bf09737c4a4f323d6da27b6589d57e439f22a6638a20a8c8b79c18cf2fe0cf7cbe1cd0c2
diff --git a/kde-frameworks/prison/prison-5.113.0.ebuild b/kde-frameworks/prison/prison-5.113.0.ebuild
new file mode 100644
index 000000000000..102102398f6a
--- /dev/null
+++ b/kde-frameworks/prison/prison-5.113.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="QRCode and data matrix barcode library"
+HOMEPAGE="https://invent.kde.org/frameworks/prison"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="qml"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ media-gfx/qrencode:=
+ media-libs/libdmtx
+ media-libs/zxing-cpp:=
+ qml? ( >=dev-qt/qtdeclarative-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt5Quick)
+ )
+
+ ecm_src_configure
+}