summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-09-10 13:25:46 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-09-10 13:43:53 +0200
commitbcb821c75406c7797b0909aa564f47538c0bff24 (patch)
treeccf750ced4c741d8a51fa4a194278cf0bff287d0 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.110.0 version bump (diff)
downloadgentoo-bcb821c75406c7797b0909aa564f47538c0bff24.tar.gz
gentoo-bcb821c75406c7797b0909aa564f47538c0bff24.tar.bz2
gentoo-bcb821c75406c7797b0909aa564f47538c0bff24.zip
kde-frameworks/purpose: 5.110.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.110.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index e8374e58c945..93fa5b2ba9bd 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.108.0.tar.xz 179400 BLAKE2B 7678abe3996006acca028d300457550a667ffac743ce163009af87c9b950b159a56453dc1afe3adfb88f9a9cd8710ada7f645fdcf63da7cdb93777883166cb88 SHA512 4dd031ea685c54d06b06ad8ff24d6b7ddd68e5bf27391817889dd0cb377ebdbb8ea6e030bf215e9c93e29b61e7bd62e17ad576e6f8a4189278f6b99e47f02409
DIST purpose-5.109.0.tar.xz 180772 BLAKE2B 893a560c8fb85a4ca7400ec6dd365d94f186f491d3656a2e0a972d995d9a0f6891d99351e68f214f9ab4268db135585b80febdec56457562b323e5c0a6008f8b SHA512 432733c048ba6c4cb4c148f0043538447d4a82fed06b4158b84d222ce573cec9777f2313a1f17b4a771e9f112260cad8dd0c2e178f751723ba9eacc87703009b
+DIST purpose-5.110.0.tar.xz 180760 BLAKE2B 2bc4c11cd02fc542b9bb1ceff7539d506640c2b46e0ba9e085260067a86418ee31af14ad688025ce687225218c3fa51b8d34400e5e31e3e9faa59cf6db04ffd3 SHA512 b447abfb9a3db5929e7217025173d9316a8414ce3d23553a5049fda8d07a2b77d15a0bee669d089ad6e6e034c41e8671bf83b9ad0de7a17e57c2cfb34cabac30
diff --git a/kde-frameworks/purpose/purpose-5.110.0.ebuild b/kde-frameworks/purpose/purpose-5.110.0.ebuild
new file mode 100644
index 000000000000..a5a92b820096
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.110.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}