summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/syntax-highlighting
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/syntax-highlighting')
-rw-r--r--kde-frameworks/syntax-highlighting/Manifest1
-rw-r--r--kde-frameworks/syntax-highlighting/syntax-highlighting-5.65.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/kde-frameworks/syntax-highlighting/Manifest b/kde-frameworks/syntax-highlighting/Manifest
index bc89e0d1192f..c8c95ab82699 100644
--- a/kde-frameworks/syntax-highlighting/Manifest
+++ b/kde-frameworks/syntax-highlighting/Manifest
@@ -1 +1,2 @@
DIST syntax-highlighting-5.64.0.tar.xz 1572812 BLAKE2B 5e1b7de3bab10fb912e3c3d0d07d84a6ced1cf12b955a9a09ce4d94f3f150edd05a98334a9373a85f928b1fae8df709b0f51327f600b43402520ffeb9a44071f SHA512 3310651de68409190a203eae1e05bfad1742b656ad66a0f6e49eae9ac00e896300d10780675ca0687982c6dee2fafa5880955c86c67e8149637c8fa52842d4c7
+DIST syntax-highlighting-5.65.0.tar.xz 1574720 BLAKE2B 9a9d65109db52beb551582c34e23b224b240ddc9dedf4118d447143cf6d21c5cb65c28a483f17f92abe8fa8481d0bc647e181cb9e42e2687fbfb8e5e084d8441 SHA512 6d47024cc3851c11c9fa774fd2bca0ff8180e0a48e6b08b50e3cdb62d289d688b5736572253b96af62789181df906c9d0642ccdd4d06c545928a342c0d19e5fb
diff --git a/kde-frameworks/syntax-highlighting/syntax-highlighting-5.65.0.ebuild b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.65.0.ebuild
new file mode 100644
index 000000000000..4d22a5f23dcf
--- /dev/null
+++ b/kde-frameworks/syntax-highlighting/syntax-highlighting-5.65.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_TEST="forceoptional"
+QTMIN=5.12.3
+inherit ecm kde.org
+
+DESCRIPTION="Framework for syntax highlighting"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="nls"
+
+BDEPEND="
+ dev-lang/perl
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtxmlpatterns-${QTMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ ecm_src_install
+ dobin "${BUILD_DIR}"/bin/katehighlightingindexer
+}