summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-10-11 19:36:26 +0200
committerMichael Palimaka <kensington@gentoo.org>2016-10-13 05:06:35 +1100
commite559b1743038622ade87249c595dd945a2827b7f (patch)
tree3807d81d8966e59519e9fcaff8f72c1b101cbb82 /kde-plasma/kinfocenter
parentkde-frameworks: remove 5.23.0 (diff)
downloadgentoo-e559b1743038622ade87249c595dd945a2827b7f.tar.gz
gentoo-e559b1743038622ade87249c595dd945a2827b7f.tar.bz2
gentoo-e559b1743038622ade87249c595dd945a2827b7f.zip
kde-plasma: 5.8.1 version bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-plasma/kinfocenter')
-rw-r--r--kde-plasma/kinfocenter/Manifest1
-rw-r--r--kde-plasma/kinfocenter/kinfocenter-5.8.1.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/kde-plasma/kinfocenter/Manifest b/kde-plasma/kinfocenter/Manifest
index 04d7862aa124..4a9670f5f302 100644
--- a/kde-plasma/kinfocenter/Manifest
+++ b/kde-plasma/kinfocenter/Manifest
@@ -2,3 +2,4 @@ DIST glogo-small.png 24583 SHA256 0afc3eca084c327f8059166b86769f03c9c23e1e765bb4
DIST kinfocenter-5.6.5.tar.xz 1409784 SHA256 9425fde6d1f92940a85449d01de6521c963c2ebf7b30b79f31c3f4b8e65629b2 SHA512 4b1692a6b2f1d3aba369463ad5aaa9910906178cf0d447e76366e9c0c4c50bc9de1a850bff149bc4bc52af14a67d68d26cafa5edd1de69e6cdb9995820bc91b8 WHIRLPOOL 340a2e3476a95c5499852f8654f285ca6e46f7d866fa91f62fb6cf7d2ebaea6580871377d81961bd0f11d6f37ebb588fc5b3d586c5e6b12ad7b660dd7ce96b7d
DIST kinfocenter-5.7.5.tar.xz 1248860 SHA256 f9cdf5575d332c4bd7f46238d3cd957a27b534a0e163d58fc7844bbc65115238 SHA512 3e08f2782004b56440395a5643f42b56a4adf6380eab15711a2397d20539e9116724f846f93a0db8bea9526f76db8c656fbda750e9742f5c9e0e33c060f0de1d WHIRLPOOL 5444078909e720501042aafc5420f60a2611d95f7cf578eee638d3f9a1d048830fcc2b66b607afa2a1c098a7cee70ea32eacb7e7604ccd7654ec0aca0a871618
DIST kinfocenter-5.8.0.tar.xz 1250340 SHA256 dfd8a237a2081e41a006f1978190ec9954be6b5545eaba2bf8daa17958d2590a SHA512 24c387e65666cf576990f80a19e10334010e029c23afe291ca77abb9d51cfa59fdc28cdb25d0c514a9411cfb66dec293366fdc2a50e1093687544c30da815bed WHIRLPOOL e095ca082e6ccc330b9a77ccdc65154e07677a91a92dc3701009da5ed08c6ce999244bc3391de5aa4062464c6eb07c9b31d6e835700c769c6adede2ab6883aa2
+DIST kinfocenter-5.8.1.tar.xz 1250684 SHA256 adf14bf48bb457ea82c4c61149630e648fe2449b512cad282d14e0cb4f825945 SHA512 8c39688edeb3c352bbe6b307a1e2449b997dd96be141b2da3972929328bfe9b149a95dc6ba5bc60c4d928ad6e3683742c690605aed793ebebbda1b23d0e95e41 WHIRLPOOL bc5126804f7bb519ee02df5343de2b4cf00e98b73faa35f1d03dab7b7052f81cd80ab61057a8026a51f05f57bca8cf5bf997ddc81fa541ad2db60c51e0bec105
diff --git a/kde-plasma/kinfocenter/kinfocenter-5.8.1.ebuild b/kde-plasma/kinfocenter/kinfocenter-5.8.1.ebuild
new file mode 100644
index 000000000000..cc6f2171f282
--- /dev/null
+++ b/kde-plasma/kinfocenter/kinfocenter-5.8.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="true"
+inherit kde5
+
+DESCRIPTION="A utility that provides information about a computer system"
+HOMEPAGE="https://www.kde.org/applications/system/kinfocenter/"
+SRC_URI+=" https://www.gentoo.org/assets/img/logo/gentoo-3d-small.png -> glogo-small.png"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="egl gles2 ieee1394 +opengl +pci wayland"
+
+REQUIRED_USE="egl? ( || ( gles2 opengl ) )"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ x11-libs/libX11
+ ieee1394? ( sys-libs/libraw1394 )
+ opengl? (
+ $(add_qt_dep qtgui 'gles2=')
+ media-libs/mesa[egl?,gles2?]
+ !gles2? ( media-libs/glu )
+ )
+ pci? ( sys-apps/pciutils )
+ wayland? ( $(add_frameworks_dep kwayland) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep plasma)
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ !kde-base/kcontrol:4
+ !kde-base/kinfocenter:4
+ !kde-misc/about-distro
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package egl EGL)
+ $(cmake-utils_use_find_package gles2 OpenGLES)
+ $(cmake-utils_use_find_package ieee1394 RAW1394)
+ $(cmake-utils_use_find_package opengl OpenGL)
+ $(cmake-utils_use_find_package pci PCIUTILS)
+ $(cmake-utils_use_find_package wayland KF5Wayland)
+ )
+
+ kde5_src_configure
+}
+
+src_install() {
+ kde5_src_install
+
+ insinto /etc/xdg
+ doins "${FILESDIR}"/kcm-about-distrorc
+
+ insinto /usr/share/${PN}
+ doins "${DISTDIR}"/glogo-small.png
+}
+
+pkg_postinst() {
+ if ! has_version "net-fs/nfs-utils"; then
+ einfo "Installing net-fs/nfs-utils will enable the NFS information module."
+ fi
+ if ! has_version "net-fs/samba" || ! has_version "net-fs/samba[server]"; then
+ einfo "Installing net-fs/samba[server(+)] will enable the Samba status information module."
+ fi
+}