summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-16 17:09:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-16 18:31:26 +0200
commitb074fa5eec76d41eb3c8c23687f68a8c74b32da2 (patch)
treeefb6d058bba9e96ad2123750a2393a1c41e64a3a /kde-plasma/kwallet-pam
parentkde-plasma/ksystemstats: 6.1.3 version bump (diff)
downloadgentoo-b074fa5eec76d41eb3c8c23687f68a8c74b32da2.tar.gz
gentoo-b074fa5eec76d41eb3c8c23687f68a8c74b32da2.tar.bz2
gentoo-b074fa5eec76d41eb3c8c23687f68a8c74b32da2.zip
kde-plasma/kwallet-pam: 6.1.3 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-6.1.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index b7332e83d350..39467e090549 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.27.11.tar.xz 22948 BLAKE2B 1c0cf86bb7e57696e44ac34a4392d1f81a6ade8fbaef6c61eefc79df39890aa1799ddbb39ec59fbde3ea4536c1113c1147b28bcdfc898049e847af99b107267b SHA512 b52177df434bf71214874a2410637240bb5a23f0fd06d41f3b62630d90e5262a231012c4f11119f96c151bb222e73652e5e8506ccc26c7cc451090f3bd156b6a
DIST kwallet-pam-6.1.2.tar.xz 22520 BLAKE2B 0f8def4fba84ffcc949cdf5ba497810cfef9df858dd39a05733aae8f9c6bb546ebc3ff5347ecf8c1b0425bb174f0a18749d0a7eb3fb5dcf327b1b663d71243a8 SHA512 22e77644a095f940b3d9ec1eb51d04a52ec81356ed6a337065dd5ae63e762e7285ef2a29bc3c314f17bcf46021fcb67c89afdc5f1fcbf24859d724e0da674f76
+DIST kwallet-pam-6.1.3.tar.xz 22520 BLAKE2B f1bc67db53a9f0b9d2270dc73ee42e5c7f94356ab5a484b8082ab8db52434a656a49390933a506fbff2a72b646893cfc12c0da018f77478b12e78050da1a6c71 SHA512 355253a413152ebcb2bd15e00a9682de7efa5330b6d5e70c5b6f4c4485387b8a2468dc1d0dbf6cb9b162b1b1dc536b953877721126e9045002add8444e969f08
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-6.1.3.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-6.1.3.ebuild
new file mode 100644
index 000000000000..af7a2a69fb2c
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-6.1.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=6.3.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+
+LICENSE="LGPL-2.1"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:6
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:6."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}