summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-06 10:19:47 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-07 07:18:37 +0200
commit141545e3a8f926a91a9ce2c190e18b57ff193484 (patch)
treed0d16d1fb15108ab59c465c9f6e070e80e7159bb /kde-plasma/libkworkspace
parentkde-plasma/xembed-sni-proxy: treeclean (diff)
downloadgentoo-141545e3a8f926a91a9ce2c190e18b57ff193484.tar.gz
gentoo-141545e3a8f926a91a9ce2c190e18b57ff193484.tar.bz2
gentoo-141545e3a8f926a91a9ce2c190e18b57ff193484.zip
kde-plasma/libkworkspace: treeclean
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/libkworkspace')
-rw-r--r--kde-plasma/libkworkspace/Manifest1
-rw-r--r--kde-plasma/libkworkspace/files/libkworkspace-5.27.9-standalone.patch108
-rw-r--r--kde-plasma/libkworkspace/libkworkspace-5.27.11.ebuild51
-rw-r--r--kde-plasma/libkworkspace/metadata.xml11
4 files changed, 0 insertions, 171 deletions
diff --git a/kde-plasma/libkworkspace/Manifest b/kde-plasma/libkworkspace/Manifest
deleted file mode 100644
index 156526552da7..000000000000
--- a/kde-plasma/libkworkspace/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST plasma-workspace-5.27.11.tar.xz 19486864 BLAKE2B 41da7e904b08e6c6dc7600c601183a9b600e68f122e1f9aae3dfec468adc1eff377566aadc52084648840be227106e7e0aa8cf48ffc7301a6853dc1c0ad92d4b SHA512 d49b717bf4b074cd201a6807329d73d0defebc814c2d3dc2eb473e00bf030d1334fe9eb8cc8b3f3e019b54faf67dcc992c5a7bef1c85d7d2fb8ee70a6c6b3443
diff --git a/kde-plasma/libkworkspace/files/libkworkspace-5.27.9-standalone.patch b/kde-plasma/libkworkspace/files/libkworkspace-5.27.9-standalone.patch
deleted file mode 100644
index 85eddb74b513..000000000000
--- a/kde-plasma/libkworkspace/files/libkworkspace-5.27.9-standalone.patch
+++ /dev/null
@@ -1,108 +0,0 @@
-From 2360505a8f6475b6988efa60c3ba746bfbe4c4d0 Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <asturm@gentoo.org>
-Date: Sun, 2 Feb 2020 18:29:57 +0100
-Subject: [PATCH] libkworkspace: Allow standalone build
-
----
- libkworkspace/CMakeLists.txt | 67 +++++++++++++++++++++++++++++++++++-
- 1 file changed, 66 insertions(+), 1 deletion(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 015c5181f..0aa635e11 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -1,3 +1,56 @@
-+project(libkworkspace)
-+
-+if(${CMAKE_SOURCE_DIR} STREQUAL ${libkworkspace_SOURCE_DIR})
-+ set(PROJECT_VERSION "GENTOO_PV")
-+ set(PROJECT_VERSION_MAJOR 5)
-+
-+ cmake_minimum_required(VERSION 3.16)
-+
-+ set(QT_MIN_VERSION "5.15.0")
-+ set(KF5_MIN_VERSION "5.82.0")
-+ find_package(Qt5 ${QT_MIN_VERSION} CONFIG REQUIRED COMPONENTS Core DBus)
-+ find_package(ECM ${KF5_MIN_VERSION} REQUIRED NO_MODULE)
-+ set(CMAKE_MODULE_PATH ${ECM_MODULE_PATH} ${ECM_KDE_MODULE_DIR})
-+
-+ include(KDEInstallDirs)
-+ include(KDECMakeSettings)
-+ include(KDECompilerSettings NO_POLICY_SCOPE)
-+ include(ECMMarkNonGuiExecutable)
-+ include(CMakePackageConfigHelpers)
-+ include(WriteBasicConfigVersionFile)
-+ include(CheckIncludeFiles)
-+ include(FeatureSummary)
-+ include(ECMQtDeclareLoggingCategory)
-+ include(KDEPackageAppTemplates)
-+ include(ECMMarkAsTest)
-+ include(GenerateExportHeader)
-+
-+ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS Config CoreAddons I18n WindowSystem)
-+
-+ find_package(KWinDBusInterface CONFIG REQUIRED)
-+ find_package(KScreenLocker 5.13.80 REQUIRED)
-+ find_package(ScreenSaverDBusInterface CONFIG REQUIRED)
-+
-+ find_package(X11)
-+ set_package_properties(X11 PROPERTIES DESCRIPTION "X11 libraries"
-+ URL "http://www.x.org"
-+ TYPE OPTIONAL
-+ PURPOSE "Required for X11 support")
-+
-+ if(X11_FOUND)
-+ find_package(Qt5X11Extras ${QT_MIN_VERSION} CONFIG REQUIRED)
-+ set(HAVE_X11 1)
-+ endif()
-+
-+ if(BUILD_TESTING)
-+ find_package(Qt5Test ${QT_MIN_VERSION} CONFIG REQUIRED)
-+ endif()
-+
-+ check_include_files(unistd.h HAVE_UNISTD_H)
-+
-+ configure_file(../config-workspace.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-workspace.h)
-+ configure_file(../config-X11.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-X11.h)
-+endif()
-
- set(kworkspace_LIB_SRCS kdisplaymanager.cpp
- kworkspace.cpp
-@@ -12,9 +65,17 @@ add_definitions(-DTRANSLATION_DOMAIN=\"libkworkspace\")
- qt_add_dbus_interface(kworkspace_LIB_SRCS kf5_org.kde.KLauncher.xml klauncher_interface)
- qt_add_dbus_interface(kworkspace_LIB_SRCS ${KSCREENLOCKER_DBUS_INTERFACES_DIR}/kf5_org.freedesktop.ScreenSaver.xml screenlocker_interface )
- qt_add_dbus_interface(kworkspace_LIB_SRCS ${KSCREENLOCKER_DBUS_INTERFACES_DIR}/org.kde.screensaver.xml kscreenlocker_interface )
-+if(${CMAKE_SOURCE_DIR} STREQUAL ${libkworkspace_SOURCE_DIR})
-+qt_add_dbus_interface(kworkspace_LIB_SRCS ../ksmserver/org.kde.LogoutPrompt.xml logoutprompt_interface)
-+qt_add_dbus_interface(kworkspace_LIB_SRCS ../startkde/plasma-session/org.kde.Startup.xml startup_interface)
-+qt_add_dbus_interface(kworkspace_LIB_SRCS ../startkde/plasma-shutdown/org.kde.Shutdown.xml shutdown_interface)
-+set(ksmserver_xml ../ksmserver/org.kde.KSMServerInterface.xml)
-+else()
- qt_add_dbus_interface(kworkspace_LIB_SRCS ${plasma-workspace_SOURCE_DIR}/ksmserver/org.kde.LogoutPrompt.xml logoutprompt_interface)
- qt_add_dbus_interface(kworkspace_LIB_SRCS ${plasma-workspace_SOURCE_DIR}/startkde/plasma-session/org.kde.Startup.xml startup_interface)
- qt_add_dbus_interface(kworkspace_LIB_SRCS ${plasma-workspace_SOURCE_DIR}/startkde/plasma-shutdown/org.kde.Shutdown.xml shutdown_interface)
-+set(ksmserver_xml ${plasma-workspace_SOURCE_DIR}/ksmserver/org.kde.KSMServerInterface.xml)
-+endif()
-
- set_source_files_properties("${CMAKE_CURRENT_SOURCE_DIR}/org.freedesktop.login1.Manager.xml"
- "${CMAKE_SOURCE_DIR}/data/interfaces/org.freedesktop.login1.Seat.xml"
-@@ -30,7 +91,6 @@ list(APPEND kworkspace_LIB_SRCS "${CMAKE_CURRENT_SOURCE_DIR}/login1_manager_inte
- qt_add_dbus_interface(kworkspace_LIB_SRCS "org.freedesktop.UPower.xml" upower_interface)
- qt_add_dbus_interface(kworkspace_LIB_SRCS "org.freedesktop.ConsoleKit.Manager.xml" consolekit_manager_interface)
-
--set(ksmserver_xml ${plasma-workspace_SOURCE_DIR}/ksmserver/org.kde.KSMServerInterface.xml)
- qt_add_dbus_interface( kworkspace_LIB_SRCS ${ksmserver_xml} ksmserver_interface )
-
- add_library(kworkspace ${kworkspace_LIB_SRCS})
-@@ -98,3 +158,8 @@ if(BUILD_TESTING)
- add_subdirectory(autotests)
- add_subdirectory(tests)
- endif()
-+
-+if ("${CMAKE_BINARY_DIR}" STREQUAL "${CMAKE_CURRENT_BINARY_DIR}")
-+ install( FILES sessionmanagementbackend.h DESTINATION ${KDE_INSTALL_INCLUDEDIR}/kworkspace5 COMPONENT Devel )
-+ feature_summary(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
-+endif()
---
-2.31.1
-
diff --git a/kde-plasma/libkworkspace/libkworkspace-5.27.11.ebuild b/kde-plasma/libkworkspace/libkworkspace-5.27.11.ebuild
deleted file mode 100644
index f22da375b176..000000000000
--- a/kde-plasma/libkworkspace/libkworkspace-5.27.11.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-ECM_TEST="true"
-KDE_ORG_NAME="plasma-workspace"
-KFMIN=5.106.0
-PVCUT=$(ver_cut 1-3)
-QTMIN=5.15.9
-inherit ecm plasma.kde.org
-
-DESCRIPTION="Workspace library to interact with the Plasma session manager"
-S="${S}/${PN}"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="amd64 ~arm arm64 ~loong ~ppc64 ~riscv x86"
-IUSE=""
-
-RDEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtx11extras-${QTMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-plasma/kscreenlocker-${PVCUT}:5
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- x11-libs/libXau
-"
-DEPEND="${RDEPEND}
- >=kde-plasma/kwin-${PVCUT}:5
-"
-
-src_prepare() {
- # delete colliding libkworkspace translations, let ecm_src_prepare do its magic
- find ../po -type f -name "*po" -and -not -name "libkworkspace*" -delete || die
- rm -rf po/*/docs || die
- cp -a ../po ./ || die
-
- eapply "${FILESDIR}/${PN}-5.27.9-standalone.patch"
- sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" -i CMakeLists.txt || die
- cat >> CMakeLists.txt <<- _EOF_ || die
- ki18n_install(po)
- _EOF_
-
- ecm_src_prepare
-}
diff --git a/kde-plasma/libkworkspace/metadata.xml b/kde-plasma/libkworkspace/metadata.xml
deleted file mode 100644
index d925f2439758..000000000000
--- a/kde-plasma/libkworkspace/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- <name>Gentoo KDE Project</name>
- </maintainer>
- <upstream>
- <bugs-to>https://bugs.kde.org/</bugs-to>
- </upstream>
-</pkgmetadata>