summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-04-19 19:56:56 +0200
committerJohannes Huber <johu@gentoo.org>2016-04-19 19:56:56 +0200
commit3f9d0e9c17863c7e543d1262245a4e70ef52b43b (patch)
treee1c024a49c8768a977468796610b1df903d2ace9 /kde-plasma/plasma-mediacenter
parentnet-analyzer/ripe-atlas-tools: Fixed dependencies for net-libs/ripe-atlas-sag... (diff)
downloadgentoo-3f9d0e9c17863c7e543d1262245a4e70ef52b43b.tar.gz
gentoo-3f9d0e9c17863c7e543d1262245a4e70ef52b43b.tar.bz2
gentoo-3f9d0e9c17863c7e543d1262245a4e70ef52b43b.zip
kde-plasma: Version bump KDE Plasma 5.6.3
Package-Manager: portage-2.2.28
Diffstat (limited to 'kde-plasma/plasma-mediacenter')
-rw-r--r--kde-plasma/plasma-mediacenter/Manifest1
-rw-r--r--kde-plasma/plasma-mediacenter/plasma-mediacenter-5.6.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/kde-plasma/plasma-mediacenter/Manifest b/kde-plasma/plasma-mediacenter/Manifest
index cb394f1895ff..a2ff466789aa 100644
--- a/kde-plasma/plasma-mediacenter/Manifest
+++ b/kde-plasma/plasma-mediacenter/Manifest
@@ -1,2 +1,3 @@
DIST plasma-mediacenter-5.5.5.tar.xz 161388 SHA256 1231f770032a445b3285765112024bb75e1f47791f58136cb932b92e95c63dfa SHA512 cf02cedb251e891ed479241a3ac3f25934454b9296e1fd795271d0e6e25da02c39e311b229faba19a458cfefb0191bb3edef3f90a6c3437daf1e597123601f96 WHIRLPOOL 90910e67f068b465fbb388009d614f24f3922708ccf86cb18d238dcf90755fbffdb3fea57ccaf9314dc48a21c77ace932fbb15552712de8e7f026f1c7020cf34
DIST plasma-mediacenter-5.6.2.tar.xz 174356 SHA256 a672db9e4ee0caa421b9023ff043b12a1a625d7908f6632cec1be6b4139b8e47 SHA512 809cc162dd78b0b1622eb3a6cc077c58847edd8302dd518d75b39221e2737e5b930c4cc8ec222cf9953e228c9eab63d8450f8fda0a82335feac4adfe03e02bf5 WHIRLPOOL b4ea751ea6ffbef7396de972dd5ff6a568cd01c28b1eadf530d59cffd8d1e367131d9baa4e7561accae7d79ed89f79344e6ec737583e60d80b6b3f04aa65e343
+DIST plasma-mediacenter-5.6.3.tar.xz 174416 SHA256 f8693597d4d92f433acbbaccb5c724672e0b41f0e9123702592e6a2cef84e59d SHA512 80ae945ce6c0aaa9a82b1095cff3beefdd58b1c7a698fd1c8ef1b0409657415466447aa114e3006ba28ec56d6a26ea7e1abb9e8ca6088a7e9116b15e2c103317 WHIRLPOOL def3272c7bf5fb53ef26db7f4ff18fa47d155ef284769e305f701d53450e1b7581a76afbfca87ed9535bb1384164c533eb57ed4cae0bd15aed3f7a5fc2074970
diff --git a/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.6.3.ebuild b/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.6.3.ebuild
new file mode 100644
index 000000000000..b1b0d084431d
--- /dev/null
+++ b/kde-plasma/plasma-mediacenter/plasma-mediacenter-5.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_TEST="forceoptional"
+inherit kde5
+
+DESCRIPTION="Unified media experience for any device capable of running KDE"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="semantic-desktop"
+
+DEPEND="
+ $(add_frameworks_dep kactivities)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtxml)
+ media-libs/taglib
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep plasma-workspace)
+ $(add_qt_dep qtmultimedia 'qml')
+ !media-video/plasma-mediacenter
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetadata)
+ )
+
+ kde5_src_configure
+}