summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-06-21 23:09:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-06-23 15:48:43 +0200
commitea5a3c2e6e5933a8fbf6e0ad5212a78d69aca65f (patch)
treef1e61416c71053097ef88184340cedcbbb2df5c0 /kde-plasma/plasma-workspace
parentkde-plasma/plasma-nm: [2/2] Fix password is asked twice (diff)
downloadgentoo-ea5a3c2e6e5933a8fbf6e0ad5212a78d69aca65f.tar.gz
gentoo-ea5a3c2e6e5933a8fbf6e0ad5212a78d69aca65f.tar.bz2
gentoo-ea5a3c2e6e5933a8fbf6e0ad5212a78d69aca65f.zip
kde-plasma/plasma-workspace: systray [2/4]: Fix unreadable text w/ Breeze Dark
See also: https://mail.kde.org/pipermail/distributions/2020-June/000368.html KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=422684 Upstream commit faef126255222f727219bf69ac2b89857dc61ab2 "Port applets to use PlasmaExtras.PlaceholderMessage" Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/plasma-workspace')
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.19.2-use-PlasmaExtras.PlaceholderMessage.patch44
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.19.2.ebuild5
2 files changed, 48 insertions, 1 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.19.2-use-PlasmaExtras.PlaceholderMessage.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.19.2-use-PlasmaExtras.PlaceholderMessage.patch
new file mode 100644
index 000000000000..527e199cc66d
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.19.2-use-PlasmaExtras.PlaceholderMessage.patch
@@ -0,0 +1,44 @@
+From faef126255222f727219bf69ac2b89857dc61ab2 Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Sun, 14 Jun 2020 09:08:21 -0600
+Subject: [PATCH] Port applets to use PlasmaExtras.PlaceholderMessage
+
+The Kirigami version uses QQC2 elements which don't respect the plasma
+theme and color scheme, leading to thing slooking out of place
+especially when using a dark color theme or scheme.
+
+Depends on https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/13
+---
+ applets/clipboard/contents/ui/Menu.qml | 2 +-
+ .../notifications/package/contents/ui/FullRepresentation.qml | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/applets/clipboard/contents/ui/Menu.qml b/applets/clipboard/contents/ui/Menu.qml
+index 0bd6064a5..cac8380db 100644
+--- a/applets/clipboard/contents/ui/Menu.qml
++++ b/applets/clipboard/contents/ui/Menu.qml
+@@ -55,7 +55,7 @@ PlasmaExtras.ScrollArea {
+ onAction: menu.action(uuid)
+ }
+
+- Kirigami.PlaceholderMessage {
++ PlasmaExtras.PlaceholderMessage {
+ id: emptyHint
+
+ anchors.centerIn: parent
+diff --git a/applets/notifications/package/contents/ui/FullRepresentation.qml b/applets/notifications/package/contents/ui/FullRepresentation.qml
+index b34dee7af..989cb4341 100644
+--- a/applets/notifications/package/contents/ui/FullRepresentation.qml
++++ b/applets/notifications/package/contents/ui/FullRepresentation.qml
+@@ -585,7 +585,7 @@ PlasmaComponents3.Page {
+ }
+ }
+
+- Kirigami.PlaceholderMessage {
++ PlasmaExtras.PlaceholderMessage {
+ anchors.centerIn: parent
+ width: parent.width - (units.largeSpacing * 4)
+
+--
+2.27.0
+
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.19.2.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.19.2.ebuild
index c14dfc3f1960..f7116713959b 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-5.19.2.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.19.2.ebuild
@@ -123,7 +123,10 @@ PDEPEND="
>=kde-plasma/kde-cli-tools-${PVCUT}:5
"
-PATCHES=( "${FILESDIR}/${PN}-5.14.2-split-libkworkspace.patch" )
+PATCHES=(
+ "${FILESDIR}/${PN}-5.14.2-split-libkworkspace.patch"
+ "${FILESDIR}/${PN}-5.19.2-use-PlasmaExtras.PlaceholderMessage.patch" # KDE-Bug #422684
+)
RESTRICT+=" test"