summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-22 21:38:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-23 19:29:43 +0100
commit706658857034d7fc09b012e90204fbeaac9be017 (patch)
tree320003e043c46a213dd19849313cd2b0c24d8d98 /kde-plasma/print-manager
parentkde-plasma/powerdevil: 5.91.0 version bump (diff)
downloadgentoo-706658857034d7fc09b012e90204fbeaac9be017.tar.gz
gentoo-706658857034d7fc09b012e90204fbeaac9be017.tar.bz2
gentoo-706658857034d7fc09b012e90204fbeaac9be017.zip
kde-plasma/print-manager: 5.91.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/print-manager')
-rw-r--r--kde-plasma/print-manager/Manifest1
-rw-r--r--kde-plasma/print-manager/print-manager-5.91.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/kde-plasma/print-manager/Manifest b/kde-plasma/print-manager/Manifest
index 02d5734bef9e..942d2d8c1ec0 100644
--- a/kde-plasma/print-manager/Manifest
+++ b/kde-plasma/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-23.08.3.tar.xz 289328 BLAKE2B e705ea40a4330e46903430070911eed416e529d045a7bee916052386a737ddaed5b8b6d92951046a804944f20636f9b3570cf8ce5d5f7770e27df148adac3dad SHA512 49d27aad5a743b700e6f46f92573e27c0595923044c3dcd30478f711ee3133de3f69f7a41fe17b8b047ab75463f213053a78d0e3a7860e84055a94b309b89a57
DIST print-manager-23.08.4.tar.xz 289936 BLAKE2B 904ed56a62f8e91beb7179fac171a1af4d8c6292bc86afe931dd5644ee18e0a883c3e29fc5b37dbd60eeddadb349626abc4c14a5bf2c7d32b78da77a40f063de SHA512 3c527ea57d78492a77252b9c5d22e476ef05531bb154c3bd7d986dcb0bbd87c0811b8e3e354f5da94ed58bdf4d7a119d648b80b2ad8689cabe332fb9265e78d3
+DIST print-manager-5.91.0.tar.xz 327664 BLAKE2B 12ca6adb082f1a2de6616f86007da2dba4fad377619af47feccf69b82215629a6ed8bbd10a41a3dd8987acc2e73f0712f39a97f9d82b62cc3d4b571a7a4c8851 SHA512 0857dd57e93803c5f86ea530d8755a7bc7f1d29c9fc24979768ca5f71dd1e9088bf9daa4668fbbf5abb6057ced3b23d6abaeb6e30990d6bbd92023a44fe921d4
diff --git a/kde-plasma/print-manager/print-manager-5.91.0.ebuild b/kde-plasma/print-manager/print-manager-5.91.0.ebuild
new file mode 100644
index 000000000000..1065209d994c
--- /dev/null
+++ b/kde-plasma/print-manager/print-manager-5.91.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.247.0
+PVCUT=$(ver_cut 1-3)
+QTMIN=6.6.0
+inherit ecm plasma.kde.org
+
+DESCRIPTION="Manage CUPS print jobs and printers in Plasma"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="+gtk"
+
+DEPEND="
+ dev-libs/kirigami-addons:6
+ >=dev-qt/qt5compat-${QTMIN}:6
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kdbusaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kiconthemes-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/kirigami-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kservice-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6
+ >=kde-plasma/libplasma-${PVCUT}:6
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/print-manager-23.08.5-r100:5
+ >=kde-frameworks/kdeclarative-${KFMIN}:6
+ kde-plasma/kde-cli-tools:*
+ gtk? ( app-admin/system-config-printer )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ if [[ -z "${REPLACING_VERSIONS}" ]] && ! use gtk ; then
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ fi
+}