summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-12 20:39:24 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-12 20:41:48 +0100
commit30026b45f60eff6506c3385a4c85c7d7b64958e5 (patch)
tree9047352a4c753df82973e1ce93ccb63904a2ae34 /kde-plasma/xembed-sni-proxy
parentRevert "net-irc/irssi: Restore some random keywords" (diff)
downloadgentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.tar.gz
gentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.tar.bz2
gentoo-30026b45f60eff6506c3385a4c85c7d7b64958e5.zip
kde-plasma: Add KDE Plasma 5.15.0
Package-Manager: Portage-2.3.60, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xembed-sni-proxy')
-rw-r--r--kde-plasma/xembed-sni-proxy/Manifest1
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/Manifest b/kde-plasma/xembed-sni-proxy/Manifest
index 9c91c2b67a13..c29e646d0ccc 100644
--- a/kde-plasma/xembed-sni-proxy/Manifest
+++ b/kde-plasma/xembed-sni-proxy/Manifest
@@ -1 +1,2 @@
DIST plasma-workspace-5.14.5.tar.xz 4578556 BLAKE2B 3c37bd9f880225f0e8b2496b90e5afc5ad591e8e356bd68ae135c3e9ccfe646adcb2418e2e80185f396c3b412f0df603ba0902e5a6d54a6d9a5abdff500a71f7 SHA512 247abdfe4ed4c7b6bb847c5352b3df11d110d59f8cc62b51dfd9de76c62549a0191efdd1e1f5a6ab82a87eccdc9fd28481a85c1252d05595e0f1a72174b3f8c6
+DIST plasma-workspace-5.15.0.tar.xz 4706936 BLAKE2B f1f772bf0c27b491ed2e8b9e4342694b5e1acaabec701ca44b252fb522c72688be1bf4c8db8826e5c7cd407c47ca1c205ae422312532bb7ea2dce165d9b9204e SHA512 2ed2f0ce2ef15aafa337a2b4943389668d18e18f026df67950f4d506d2c5647660ddade6f9c915b1e2fb36c79fbcddf563c25fdac69aac3f14e26afb603c533c
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.0.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.0.ebuild
new file mode 100644
index 000000000000..9b2a7e4bffcc
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.15.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KDE_AUTODEPS="false"
+KMNAME="plasma-workspace"
+inherit kde5
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="
+ $(add_frameworks_dep extra-cmake-modules)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/plasma-workspace-5.14.2:5
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.14.90-standalone.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/$(ver_cut 1-3)/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}