summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdel KARA SLIMANE <adel.ks@zegrapher.com>2021-11-06 13:59:39 +0100
committerSam James <sam@gentoo.org>2022-01-21 19:06:50 +0000
commit425b220ffec311f718d667af865da9d5f1a4ff14 (patch)
treeb31ca5a64ee2c6e567ed66b416ec34b556a9e4f8 /lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild
parentlxqt-base/lxqt-sudo: version bump to 1.0.0 (diff)
downloadgentoo-425b220ffec311f718d667af865da9d5f1a4ff14.tar.gz
gentoo-425b220ffec311f718d667af865da9d5f1a4ff14.tar.bz2
gentoo-425b220ffec311f718d667af865da9d5f1a4ff14.zip
lxqt-base/lxqt-runner: version bump to 1.0.0
Signed-off-by: Adel KARA SLIMANE <adel.ks@zegrapher.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild')
-rw-r--r--lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild b/lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild
new file mode 100644
index 000000000000..070c3c3d99d4
--- /dev/null
+++ b/lxqt-base/lxqt-runner/lxqt-runner-1.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt quick launcher"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-cpp/muParser-2.2.3:=
+ >=dev-libs/libqtxdg-3.3.1
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtxml-5.15:5
+ kde-frameworks/kwindowsystem:5
+ =lxqt-base/liblxqt-${MY_PV}*
+ =lxqt-base/lxqt-globalkeys-${MY_PV}*
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ cmake_src_install
+ doman man/*.1
+}