summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNP-Hardass <NP-Hardass@gentoo.org>2019-05-12 16:20:10 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2019-05-12 17:01:33 -0400
commit70f31021a198f8cf2758029df7b9e4501d165fee (patch)
tree2f8afad28a31fab0093c622c90be48b6d27f84b0 /mate-extra/mate-polkit/mate-polkit-1.22.0-r1.ebuild
parentmate-base/caja: Bump to 1.22.1 (diff)
downloadgentoo-70f31021a198f8cf2758029df7b9e4501d165fee.tar.gz
gentoo-70f31021a198f8cf2758029df7b9e4501d165fee.tar.bz2
gentoo-70f31021a198f8cf2758029df7b9e4501d165fee.zip
mate-extra/mate-polkit: fix dependencies
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'mate-extra/mate-polkit/mate-polkit-1.22.0-r1.ebuild')
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.22.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/mate-polkit-1.22.0-r1.ebuild b/mate-extra/mate-polkit/mate-polkit-1.22.0-r1.ebuild
new file mode 100644
index 000000000000..68691a62f991
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.22.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102
+ x11-libs/gdk-pixbuf:2
+ virtual/libintl:0
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libappindicator:3 )"
+
+RDEPEND="${COMMON_DEPEND}
+ accountsservice? ( sys-apps/accountsservice )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35:*
+ sys-devel/gettext:*
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}