summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-05-18 17:11:14 -0400
committerMike Frysinger <vapier@gentoo.org>2016-05-18 17:12:14 -0400
commit808cbd7400602ae010e5ab0dcdaf8db9cfa87a99 (patch)
tree254962ef9a316e78d7b6b0f9987643e4676ec465 /media-gfx/birdfont
parentkde-misc/kdeconnect: Lower dependency on kde-frameworks/kwayland (diff)
downloadgentoo-808cbd7400602ae010e5ab0dcdaf8db9cfa87a99.tar.gz
gentoo-808cbd7400602ae010e5ab0dcdaf8db9cfa87a99.tar.bz2
gentoo-808cbd7400602ae010e5ab0dcdaf8db9cfa87a99.zip
media-libs/libxmlbird & media-gfx/birdfont: switch to doit
Use the system version of doit so we can get parallel build support. The tiny bundled wrapper can only build serially.
Diffstat (limited to 'media-gfx/birdfont')
-rw-r--r--media-gfx/birdfont/birdfont-2.15.5.ebuild6
-rw-r--r--media-gfx/birdfont/files/birdfont-2.5.1-verbose.patch10
2 files changed, 3 insertions, 13 deletions
diff --git a/media-gfx/birdfont/birdfont-2.15.5.ebuild b/media-gfx/birdfont/birdfont-2.15.5.ebuild
index 2a6deaff4d5a..26b66e701d4a 100644
--- a/media-gfx/birdfont/birdfont-2.15.5.ebuild
+++ b/media-gfx/birdfont/birdfont-2.15.5.ebuild
@@ -6,7 +6,7 @@ EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
PLOCALES="cs de it sv"
-inherit python-any-r1 vala l10n toolchain-funcs multilib eutils
+inherit python-any-r1 vala l10n toolchain-funcs multilib eutils multiprocessing
DESCRIPTION="free font editor which lets you create vector graphics and export TTF, EOT and SVG fonts"
HOMEPAGE="https://birdfont.org/"
@@ -34,13 +34,13 @@ RDEPEND="dev-db/sqlite:3
)"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/doit[${PYTHON_USEDEP}]')
$(vala_depend)
nls? ( sys-devel/gettext )"
src_prepare() {
vala_src_prepare
- epatch "${FILESDIR}"/${PN}-2.5.1-verbose.patch
epatch "${FILESDIR}"/${PN}-2.15.5-configure-valac.patch
sed -i \
@@ -75,7 +75,7 @@ src_configure() {
}
src_compile() {
- v ./build.py
+ v doit run -n $(makeopts_jobs)
}
src_install() {
diff --git a/media-gfx/birdfont/files/birdfont-2.5.1-verbose.patch b/media-gfx/birdfont/files/birdfont-2.5.1-verbose.patch
deleted file mode 100644
index b44a28de2303..000000000000
--- a/media-gfx/birdfont/files/birdfont-2.5.1-verbose.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/scripts/run.py
-+++ b/scripts/run.py
-@@ -20,6 +20,7 @@ import subprocess
-
- def run(cmd):
- cmd = "sh -c \"" + cmd.replace ("\"", "\\\"") + "\""
-+ print(cmd)
- process = subprocess.Popen (cmd, shell=True)
- process.communicate()[0]
- if not process.returncode == 0: