summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-10-18 02:27:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-10-18 02:28:40 +0200
commit81778186e30816cb54047015642b12e791f979ce (patch)
treea70e714359c56d1c8169d7c5bab17c33b6410c1c /media-gfx/exiv2/files
parentmedia-gfx/exiv2: Add 0.26_p20171018 snapshot from 0.26 branch (diff)
downloadgentoo-81778186e30816cb54047015642b12e791f979ce.tar.gz
gentoo-81778186e30816cb54047015642b12e791f979ce.tar.bz2
gentoo-81778186e30816cb54047015642b12e791f979ce.zip
media-gfx/exiv2: Drop old snapshot
It was based on master when it was not clear there was going to be a stable branch. Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'media-gfx/exiv2/files')
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26_p20171013-ccache.patch62
-rw-r--r--media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch47
2 files changed, 0 insertions, 109 deletions
diff --git a/media-gfx/exiv2/files/exiv2-0.26_p20171013-ccache.patch b/media-gfx/exiv2/files/exiv2-0.26_p20171013-ccache.patch
deleted file mode 100644
index ece62cedce9c..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.26_p20171013-ccache.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 9686aa8857bcd992ee4f23d20e80dfc31679f67a Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Sun, 15 Oct 2017 09:28:09 +0200
-Subject: [PATCH] Add build switch to disable auto ccache
-
-Current usage of ccache leads to sandbox issues.
-Be able to switch it off for package managers that already can
-make use of ccache for build.
----
- CMakeLists.txt | 1 +
- config/findDependencies.cmake | 12 +++++++-----
- config/printSummary.cmake | 1 +
- 3 files changed, 9 insertions(+), 5 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 80fa907c..a60d4b2e 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -41,6 +41,7 @@ option( EXIV2_ENABLE_SSH "USE Libssh for SshIo"
- option( EXIV2_BUILD_SAMPLES "Build sample applications" ON )
- option( EXIV2_BUILD_PO "Build translations files" OFF )
- option( EXIV2_BUILD_EXIV2_COMMAND "Build exiv2 command-line executable" ON )
-+option( BUILD_WITH_CCACHE "Use ccache to speed up compile time" ON )
-
- if ( EXIV2_ENABLE_WEBREADY )
- set ( EXIV2_ENABLE_CURL ON )
-diff --git a/config/findDependencies.cmake b/config/findDependencies.cmake
-index 16967763..d6af9488 100644
---- a/config/findDependencies.cmake
-+++ b/config/findDependencies.cmake
-@@ -58,9 +58,11 @@ if( EXIV2_ENABLE_BUILD_PO )
- endif()
- endif()
-
--find_program(CCACHE_FOUND ccache)
--if(CCACHE_FOUND)
-- message(STATUS "Program ccache found")
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
-- set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
-+if( BUILD_WITH_CCACHE )
-+ find_program(CCACHE_FOUND ccache)
-+ if(CCACHE_FOUND)
-+ message(STATUS "Program ccache found")
-+ set_property(GLOBAL PROPERTY RULE_LAUNCH_COMPILE ccache)
-+ set_property(GLOBAL PROPERTY RULE_LAUNCH_LINK ccache)
-+ endif()
- endif()
-diff --git a/config/printSummary.cmake b/config/printSummary.cmake
-index 21e444a4..62ba4e98 100644
---- a/config/printSummary.cmake
-+++ b/config/printSummary.cmake
-@@ -40,6 +40,7 @@ endif()
- OptionOutput( "Building exiv2 command: " EXIV2_BUILD_EXIV2_COMMAND )
- OptionOutput( "Building samples: " EXIV2_BUILD_SAMPLES )
- OptionOutput( "Building PO files: " EXIV2_BUILD_PO )
-+OptionOutput( "Using ccache: " BUILD_WITH_CCACHE )
-
-
- message( STATUS "------------------------------------------------------------------" )
---
-2.14.2
-
diff --git a/media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch b/media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch
deleted file mode 100644
index c10f125415b2..000000000000
--- a/media-gfx/exiv2/files/exiv2-0.26_p20171013-cmake.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 57883ee664260f5a1b382575e7477ad34c86ce7d Mon Sep 17 00:00:00 2001
-From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
-Date: Fri, 13 Oct 2017 18:54:11 +0200
-Subject: [PATCH] Fix build with EXIV2_BUILD_EXIV2_COMMAND=OFF
-
----
- src/CMakeLists.txt | 17 ++++++++++++-----
- 1 file changed, 12 insertions(+), 5 deletions(-)
-
-diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
-index fe49a0a6..f75cbf1b 100644
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -291,21 +291,28 @@ if(EXIV2_BUILD_EXIV2_COMMAND)
- if ( BUILD_SHARED_LIBS )
- target_compile_definitions(exiv2 PRIVATE EXV_HAVE_DLL )
- endif()
-+ # modify source lists to suit environment
-+
-+ # TODO This should not be needed here! we need to fix the previous TODO
-+ target_include_directories(exiv2 PRIVATE ${CMAKE_SOURCE_DIR}/include/)
-+
-+ if(NOT EXV_HAVE_TIMEGM )
-+ target_sources(exiv2 PRIVATE localtime.c)
-+ endif()
-+
-+ if (MSVC)
-+ target_sources(exiv2 PRIVATE getopt_win32.c)
-+ endif()
- install(TARGETS exiv2 RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})
- endif()
-
--# TODO This should not be needed here! we need to fix the previous TODO
--target_include_directories(exiv2 PRIVATE ${CMAKE_SOURCE_DIR}/include/)
--
- # modify source lists to suit environment
- if(NOT EXV_HAVE_TIMEGM )
- target_sources(exiv2lib PRIVATE localtime.c)
-- target_sources(exiv2 PRIVATE localtime.c)
- endif()
-
- if (MSVC)
- target_sources(exiv2lib PRIVATE getopt_win32.c)
-- target_sources(exiv2 PRIVATE getopt_win32.c)
- endif()
-
- # ******************************************************************************