summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2023-07-18 19:23:06 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-07-28 17:06:54 +0300
commitae8d5803be2b1b139a22e5a4563e890db9d29e91 (patch)
tree2656a831ba1b0acad01245d74ed7c68404bc6c7a /media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild
parentmedia-gfx/gnofract4d: drop 4.3_p20211108, 4.3_p20221114 (diff)
downloadgentoo-ae8d5803be2b1b139a22e5a4563e890db9d29e91.tar.gz
gentoo-ae8d5803be2b1b139a22e5a4563e890db9d29e91.tar.bz2
gentoo-ae8d5803be2b1b139a22e5a4563e890db9d29e91.zip
media-gfx/gnofract4d: add 4.3_p20230717
Closes: https://bugs.gentoo.org/890796 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31946 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild')
-rw-r--r--media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild b/media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild
new file mode 100644
index 000000000000..f29c0f35e3e3
--- /dev/null
+++ b/media-gfx/gnofract4d/gnofract4d-4.3_p20230717.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_EXT=1
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 optfeature virtualx xdg
+
+COMMIT="47d2093e8f6399d1badfba0d1cb0f9867e90b326"
+
+DESCRIPTION="A program for drawing beautiful mathematically-based images known as fractals"
+HOMEPAGE="https://fract4d.github.io/gnofract4d/"
+SRC_URI="https://github.com/fract4d/gnofract4d/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ media-libs/libjpeg-turbo:0=
+ media-libs/libpng:0="
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ gui-libs/gtk:4[introspection]"
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ media-video/ffmpeg[vpx,zlib]
+ )"
+
+distutils_enable_tests pytest
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ sed -i -e "s:VERSION = '4.3':VERSION = '$PV':" fract4d/options.py || die
+ sed -i -e "s:share/doc/gnofract4d/:share/doc/${PF}/:" setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ ln -s "${BUILD_DIR}"/lib/fract4d/*.so fract4d/ || die
+ local EPYTEST_IGNORE=(
+ # test_regress.py does not provide pytest with any tests and inspecting it requires dev-python/pillow
+ test_regress.py
+ )
+ use x86 && local EPYTEST_DESELECT=(
+ # https://bugs.gentoo.org/890796
+ test_fractal.py::Test::testDiagonal
+ test_fractal.py::Test::testRecolor
+ )
+ TMPDIR="${T}" virtx epytest
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "creating videos" media-video/ffmpeg[vpx,zlib]
+}