summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-11-10 19:16:18 +0100
committerThomas Deutschmann <whissi@gentoo.org>2019-11-10 19:21:11 +0100
commitbf8b327562c1f785027ea79d8eda5d6ac0d0308e (patch)
treef4dcb4a1a9302b965302c16300f49ee84eb11879 /media-gfx/imagemagick/imagemagick-9999.ebuild
parentmedia-gfx/imagemagick: bump to v6.9.10-71 (diff)
downloadgentoo-bf8b327562c1f785027ea79d8eda5d6ac0d0308e.tar.gz
gentoo-bf8b327562c1f785027ea79d8eda5d6ac0d0308e.tar.bz2
gentoo-bf8b327562c1f785027ea79d8eda5d6ac0d0308e.zip
media-gfx/imagemagick: bump to v7.0.9-2
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'media-gfx/imagemagick/imagemagick-9999.ebuild')
-rw-r--r--media-gfx/imagemagick/imagemagick-9999.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/media-gfx/imagemagick/imagemagick-9999.ebuild b/media-gfx/imagemagick/imagemagick-9999.ebuild
index 1d5c3d2d7d7c..d27633e5c497 100644
--- a/media-gfx/imagemagick/imagemagick-9999.ebuild
+++ b/media-gfx/imagemagick/imagemagick-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
-inherit eapi7-ver eutils flag-o-matic libtool perl-functions toolchain-funcs multilib
+inherit flag-o-matic libtool perl-functions toolchain-funcs multilib
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/ImageMagick/ImageMagick.git"
@@ -20,9 +20,11 @@ DESCRIPTION="A collection of tools and libraries for many image formats"
HOMEPAGE="https://www.imagemagick.org/"
LICENSE="imagemagick"
-SLOT="0/${PV}"
+SLOT="0/7.0.9"
IUSE="bzip2 corefonts cxx djvu fftw fontconfig fpx graphviz hdri heif jbig jpeg jpeg2k lcms lqr lzma opencl openexr openmp pango perl png postscript q32 q8 raw static-libs svg test tiff truetype webp wmf X xml zlib"
+BDEPEND="virtual/pkgconfig"
+
RDEPEND="
dev-libs/libltdl:0
bzip2? ( app-arch/bzip2 )
@@ -62,9 +64,9 @@ RDEPEND="
xml? ( dev-libs/libxml2:= )
lzma? ( app-arch/xz-utils )
zlib? ( sys-libs/zlib:= )"
+
DEPEND="${RDEPEND}
!media-gfx/graphicsmagick[imagemagick]
- virtual/pkgconfig
X? ( x11-base/xorg-proto )"
REQUIRED_USE="corefonts? ( truetype )
@@ -150,6 +152,7 @@ src_configure() {
$(use_with jbig)
$(use_with jpeg)
$(use_with jpeg2k openjp2)
+ --without-jxl
$(use_with lcms)
$(use_with lqr)
$(use_with lzma)
@@ -200,7 +203,7 @@ src_install() {
DOCUMENTATION_PATH="${EPREFIX}"/usr/share/doc/${PF}/html \
install
- rm -f "${ED%/}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
+ rm -f "${ED}"/usr/share/doc/${PF}/html/{ChangeLog,LICENSE,NEWS.txt}
dodoc {AUTHORS,README}.txt ChangeLog
if use perl; then