summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/png2ico
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/png2ico')
-rw-r--r--media-gfx/png2ico/Manifest1
-rw-r--r--media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch13
-rw-r--r--media-gfx/png2ico/metadata.xml5
-rw-r--r--media-gfx/png2ico/png2ico-2002.12.08.ebuild41
4 files changed, 60 insertions, 0 deletions
diff --git a/media-gfx/png2ico/Manifest b/media-gfx/png2ico/Manifest
new file mode 100644
index 000000000000..e21800f420b2
--- /dev/null
+++ b/media-gfx/png2ico/Manifest
@@ -0,0 +1 @@
+DIST png2ico-src-2002-12.08.tar.gz 26527 SHA256 d6bc2b8f9dacfb8010e5f5654aaba56476df18d88e344ea1a32523bb5843b68e SHA512 f9410d2d15a14b5350cab7bf93f91b80f9e1d0b6a1fdae8b8850d11f29c9f4000bc8c3778fe24acec75f1f182d5ea383cff38e22b8ac5da6432c0a7a2d0e3208 WHIRLPOOL 66e73ec1ec91761552a832812b30862488a2fa305f22e2ed37d44533350c44bbec8bf3015ad75fe85ef76a083c1f9e82c722a2a1ab4160cf87b2ce9a7d1c3ead
diff --git a/media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch b/media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch
new file mode 100644
index 000000000000..96720bebd18f
--- /dev/null
+++ b/media-gfx/png2ico/files/png2ico-2002.12.08-memset_and_strcmp.patch
@@ -0,0 +1,13 @@
+png2ico.cpp:133:31: error: ‘memset’ was not declared in this scope
+png2ico.cpp:443:34: error: ‘strcmp’ was not declared in this scope
+
+--- png2ico.cpp
++++ png2ico.cpp
+@@ -33,6 +33,7 @@
+
+
+ #include <cstdio>
++#include <cstring>
+ #include <vector>
+ #include <climits>
+
diff --git a/media-gfx/png2ico/metadata.xml b/media-gfx/png2ico/metadata.xml
new file mode 100644
index 000000000000..e770d1bc9a96
--- /dev/null
+++ b/media-gfx/png2ico/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>
diff --git a/media-gfx/png2ico/png2ico-2002.12.08.ebuild b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
new file mode 100644
index 000000000000..d759357eb01e
--- /dev/null
+++ b/media-gfx/png2ico/png2ico-2002.12.08.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="PNG to icon converter"
+HOMEPAGE="http://winterdrache.de/freeware/png2ico/index.html"
+SRC_URI="http://winterdrache.de/freeware/${PN}/data/${PN}-src-${PV/./-}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libpng:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-memset_and_strcmp.patch
+
+ sed -i \
+ -e 's:CPPFLAGS=-W -Wall -O2:CXXFLAGS+=-W -Wall:' \
+ -e 's:g++ $(CPPFLAGS):$(CXX) $(LDFLAGS) $(CXXFLAGS):' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CXX
+ emake DEBUG=""
+}
+
+src_install() {
+ dobin png2ico
+ dodoc doc/bmp.txt README
+ doman doc/png2ico.1
+}