summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2023-07-01 00:34:13 +0300
committerSam James <sam@gentoo.org>2023-07-13 09:25:21 +0100
commitd7aad12bcff9ee2bc6da480847d8415b83415401 (patch)
treec3c2c6455c5a22b79f4f03d2a7ad65361c8314f6 /media-gfx
parentpackage.mask: mask <dev-db/mariadb-10.6 (diff)
downloadgentoo-d7aad12bcff9ee2bc6da480847d8415b83415401.tar.gz
gentoo-d7aad12bcff9ee2bc6da480847d8415b83415401.tar.bz2
gentoo-d7aad12bcff9ee2bc6da480847d8415b83415401.zip
media-gfx/gimp: 9999.ebuild. Pass LD_LIBRARY_PATH for src_test() phase.
While running the tests the gimp:2.99 tries to link system libgimp-3.0.so if gimp:2.99 is already installed. If system libgimp-3.0 has old GIMP API then it causes some tests fail. The proposed changes should fix this problem. Closes: https://bugs.gentoo.org/867856 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/31683 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
index 876a775bc120..182c61c4e356 100644
--- a/media-gfx/gimp/gimp-9999.ebuild
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -215,6 +215,11 @@ _rename_plugins() {
)
}
+src_test() {
+ local -x LD_LIBRARY_PATH="${BUILD_DIR}/libgimp:${LD_LIBRARY_PATH}"
+ meson_src_test
+}
+
src_install() {
meson_src_install