summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-05 17:47:35 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-05 17:52:24 +0200
commite0b2ded8695ba9c9d1e9a1c1b5d35337390db278 (patch)
tree703748348e0a3984103579b8771e739bd6e5215c /media-gfx
parentnet-misc/openssh: add more upstream patches (diff)
downloadgentoo-e0b2ded8695ba9c9d1e9a1c1b5d35337390db278.tar.gz
gentoo-e0b2ded8695ba9c9d1e9a1c1b5d35337390db278.tar.bz2
gentoo-e0b2ded8695ba9c9d1e9a1c1b5d35337390db278.zip
media-gfx/qrencode: Bump to 4.0.1
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/qrencode/Manifest1
-rw-r--r--media-gfx/qrencode/qrencode-4.0.1.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/media-gfx/qrencode/Manifest b/media-gfx/qrencode/Manifest
index 15ca20000cfd..37ade00b7c6e 100644
--- a/media-gfx/qrencode/Manifest
+++ b/media-gfx/qrencode/Manifest
@@ -1,2 +1,3 @@
DIST qrencode-3.4.4.tar.bz2 369136 BLAKE2B 19e9a2089c6c22284da61dda57d1150573b72833c3e9d96d1aa8742a69cb7495b3c39b8162b0dd268e94412bbc618d1358dcfd969f12c0b3e9701414955aed46 SHA512 4835d462542e37e5460635e0dd84e291ff0976a6aec61c63f9950c1e60b446bc913220726e14f6379322bfd32ccd9bcd5fceed9ca10cb95343c952d8472b983d
DIST qrencode-4.0.0.tar.bz2 429244 BLAKE2B 45fe8afe602e7ff20b750b5a0de8a3b52b61340ebf0bbcad2ae00e4a0ff2976077b5add4e2c1358d4ca852f79f4cdb27d9dab8c726bf72ff53964661335b5a0a SHA512 d4140d77fce3a1c39735cc3e98e3a19018daaa08c870644f71727d27ffb17711e76b4ed4e51718d90d812e78df75fe575617580ea9b1bf210438f8fd1734204e
+DIST qrencode-4.0.1.tar.bz2 430198 BLAKE2B 40c374c4619a9556fcd921b913cbc80d18d89683aa2be7316efd51561491df1d43fa0d386bc5a6fa7e7534be4bf645e2912004bba24d9c97840a6128c02d6033 SHA512 ee1d43f2f791757a7dd0c38364d0661daf1784a1bdd2c7a7fd1200d1cdde249fd9fcad4c8d2fa919db14e6f8e464badae88ec01ed646c693eddea69c97fcf9a0
diff --git a/media-gfx/qrencode/qrencode-4.0.1.ebuild b/media-gfx/qrencode/qrencode-4.0.1.ebuild
new file mode 100644
index 000000000000..2a5a96d032f9
--- /dev/null
+++ b/media-gfx/qrencode/qrencode-4.0.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="C library for encoding data in a QR Code symbol"
+HOMEPAGE="https://fukuchi.org/works/qrencode/"
+SRC_URI="https://fukuchi.org/works/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_with test tests)
+ # TODO: figure out how to make SDL check fail as the SDL test
+ # program is not useful
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ # from upstream's test_basic.sh, which they failed to include
+ # in dist tarball
+ local t tests=(
+ test_bitstream
+ test_estimatebit
+ test_qrencode
+ test_qrinput
+ test_qrspec
+ test_rs
+ test_split
+ test_mask
+ test_mqrspec
+ test_mmask
+ test_monkey
+ )
+
+ cd tests || die
+ for t in "${tests[@]}"; do
+ einfo "Running test: ${t} ..."
+ "./${t}" || die "Test failed: ${t}"
+ done
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}