summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/aalib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/aalib')
-rw-r--r--media-libs/aalib/Manifest1
-rw-r--r--media-libs/aalib/aalib-1.4_rc5-r6.ebuild67
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch35
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc4-m4.patch9
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch34
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch56
-rw-r--r--media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch19
-rw-r--r--media-libs/aalib/metadata.xml15
8 files changed, 236 insertions, 0 deletions
diff --git a/media-libs/aalib/Manifest b/media-libs/aalib/Manifest
new file mode 100644
index 000000000000..02f94b7f5eda
--- /dev/null
+++ b/media-libs/aalib/Manifest
@@ -0,0 +1 @@
+DIST aalib-1.4rc5.tar.gz 391028 SHA256 fbddda9230cf6ee2a4f5706b4b11e2190ae45f5eda1f0409dc4f99b35e0a70ee SHA512 3e4506eccce3b81ccbbb79a4a1b90abd39e2259e6043fde90f70b9ca279bd4c37758a047167267b97c4ec92f64fb17c7c8f548114f0d0c6e78ddb9463b5f1299 WHIRLPOOL ec98116736b64eb6e855777a5ec13894446b76beb4f874a490144919031d6ddd341b49cc429b2c918acde5cebc22a3e2dc97b949379200f441d2c544a02f2736
diff --git a/media-libs/aalib/aalib-1.4_rc5-r6.ebuild b/media-libs/aalib/aalib-1.4_rc5-r6.ebuild
new file mode 100644
index 000000000000..43e8502f0a0f
--- /dev/null
+++ b/media-libs/aalib/aalib-1.4_rc5-r6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib eutils toolchain-funcs
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${PN}-1.4.0"
+
+DESCRIPTION="A ASCII-Graphics Library"
+HOMEPAGE="http://aa-project.sourceforge.net/aalib/"
+SRC_URI="mirror://sourceforge/aa-project/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="X slang gpm static-libs"
+
+RDEPEND="X? ( >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] )
+ gpm? ( >=sys-libs/gpm-1.20.7-r2[${MULTILIB_USEDEP}] )
+ slang? ( >=sys-libs/slang-2.2.4-r1[${MULTILIB_USEDEP}] )
+ >=sys-libs/ncurses-5.9-r3[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ X? ( x11-proto/xproto )
+"
+
+DOCS="ANNOUNCE AUTHORS ChangeLog NEWS README*"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.4_rc4-gentoo.patch
+ epatch "${FILESDIR}"/${PN}-1.4_rc4-m4.patch
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-fix-protos.patch #224267
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-fix-aarender.patch #214142
+ epatch "${FILESDIR}"/${PN}-1.4_rc5-tinfo.patch #468566
+
+ sed -i -e 's:#include <malloc.h>:#include <stdlib.h>:g' "${S}"/src/*.c
+
+ # Fix bug #165617.
+ use gpm || sed -i \
+ 's/gpm_mousedriver_test=yes/gpm_mousedriver_test=no/' "${S}/configure.in"
+
+ #467988 automake-1.13
+ mv configure.{in,ac} || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with slang slang-driver)
+ $(use_with X x11-driver)
+ $(use_enable static-libs static)
+ )
+
+ PKG_CONFIG=$(tc-getPKG_CONFIG) \
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+ use static-libs || prune_libtool_files --all
+}
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch
new file mode 100644
index 000000000000..4eb4a391a5be
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc4-gentoo.patch
@@ -0,0 +1,35 @@
+Fix --with-gpm-mouse usage to not be so freaky. Don't patch
+configure.in that way we avoid having to run autotools.
+
+ AC_ARG_WITH(gpm-mouse,
+ - [ --with-gpm-mouse=base-dir Specifies the base gpm directory],
+ - if test x$withval = xyes
+ + [ --with-gpm-mouse=base-dir/no Specifies the base gpm directory],
+ + if test x$withval = xno
+ then
+ - AC_MSG_WARN(Usage is: --with-gpm-mouse=base-dir)
+ + gpm_mousedriver_test=no
+ else
+--- aalib-1.4.0/configure
++++ aalib-1.4.0/configure
+@@ -28,7 +28,7 @@
+ ac_help="$ac_help
+ --with-curses-driver=no/yes Used to disable/force curses driver"
+ ac_help="$ac_help
+- --with-gpm-mouse=base-dir Specifies the base gpm directory"
++ --with-gpm-mouse=base-dir/no Specifies the base gpm directory"
+ ac_help="$ac_help
+ --with-x use the X Window System"
+ ac_help="$ac_help
+@@ -1960,9 +1960,9 @@
+ # Check whether --with-gpm-mouse or --without-gpm-mouse was given.
+ if test "${with_gpm_mouse+set}" = set; then
+ withval="$with_gpm_mouse"
+- if test x$withval = xyes
++ if test x$withval = xno
+ then
+- echo "configure: warning: Usage is: --with-gpm-mouse=base-dir" 1>&2
++ gpm_mousedriver_test=no
+ else
+ LIBS="$LIBS -L$withval/lib -lgpm"
+ cat >> confdefs.h <<\EOF
diff --git a/media-libs/aalib/files/aalib-1.4_rc4-m4.patch b/media-libs/aalib/files/aalib-1.4_rc4-m4.patch
new file mode 100644
index 000000000000..3670f19125fc
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc4-m4.patch
@@ -0,0 +1,9 @@
+Get rid of aclocal warning:
+/usr/share/aclocal/aalib.m4:12: warning: underquoted definition of AM_PATH_AALIB
+--- aalib-1.4.0/aalib.m4
++++ aalib-1.4.0/aalib.m4
+@@ -11,3 +11,3 @@
+ dnl
+-AC_DEFUN(AM_PATH_AALIB,
++AC_DEFUN([AM_PATH_AALIB],
+ [dnl
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch b/media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch
new file mode 100644
index 000000000000..97c59836b5c9
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-fix-aarender.patch
@@ -0,0 +1,34 @@
+This bug can be seen very clearly with e.g. mplayer -vo aa -monitoraspect 3
+in which case a big part of the picture is missing or there is even completely
+black output.
+
+The reason for this is, when drawing only a part of the picture via aarender()
+the first X coordinate is used for the loop count, but it is not applied to the
+destination and source image index, thus instead of (re)drawing the middle part
+of the image, it draws always the left part.
+
+Actual Results:
+only the left part of the image is draw (depending on the video, only the left
+black bar might be draw, so you will see nothing at all - if so use a slightly
+smaller value for -monitoraspect).
+
+Expected Results:
+All of the image should be drawn, and -monitoraspect should only squeeze the
+image, not cause part of it to miss.
+
+Gentoo-bug: http://bugs.gentoo.org/id=214142
+Reported-by: Reimar Döffinger
+Fixed-by: Reimar Döffinger
+--- src/aarender.c.orig 2008-03-18 23:55:32.000000000 +0100
++++ src/aarender.c 2008-03-18 23:55:50.000000000 +0100
+@@ -94,8 +94,8 @@
+ gamma = randomval / 2;
+ mval = (c->parameters[c->filltable[255]].p[4]);
+ for (y = y1; y < y2; y++) {
+- pos = 2 * y * wi;
+- pos1 = y * aa_scrwidth(c);
++ pos = 2 * (y * wi + x1);
++ pos1 = y * aa_scrwidth(c) + x1;
+ esum = 0;
+ for (x = x1; x < x2; x++) {
+ i1 = table[((((int) c->imagebuffer[pos])))];
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch b/media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch
new file mode 100644
index 000000000000..b22738a25c6c
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-fix-protos.patch
@@ -0,0 +1,56 @@
+fix missing protos
+
+ * QA Notice: Package triggers severe warnings which indicate that it
+ * may exhibit random runtime failures.
+ * aainfo.c:12:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aainfo.c:17:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aatest.c:8:5: warning: incompatible implicit declaration of built-in function 'strcpy'
+ * aatest.c:11:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aatest.c:16:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aatest.c:21:2: warning: incompatible implicit declaration of built-in function 'exit'
+ * aafire.c:55:7: warning: incompatible implicit declaration of built-in function 'exit'
+ * aafire.c:68:3: warning: incompatible implicit declaration of built-in function 'exit'
+ * aafire.c:154:7: warning: incompatible implicit declaration of built-in function 'exit'
+ * aasavefont.c:10:2: warning: incompatible implicit declaration of built-in function 'exit'
+
+Gentoo-bug: http://bugs.gentoo.org/224267
+Reported-by: Peter Hüwe
+diff --git a/src/aafire.c b/src/aafire.c
+index 4f36149..5e41237 100644
+--- a/src/aafire.c
++++ b/src/aafire.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+
+ #define XSIZ aa_imgwidth(context)
+diff --git a/src/aainfo.c b/src/aainfo.c
+index d3f6d50..e24082d 100644
+--- a/src/aainfo.c
++++ b/src/aainfo.c
+@@ -1,4 +1,4 @@
+-
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+ #include "aaint.h"
+ int main(int argc, char **argv)
+diff --git a/src/aasavefont.c b/src/aasavefont.c
+index b00e1e6..16591e8 100644
+--- a/src/aasavefont.c
++++ b/src/aasavefont.c
+@@ -1,3 +1,4 @@
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+ int main(int argc, char **argv)
+ {
+diff --git a/src/aatest.c b/src/aatest.c
+index 9816f5d..ed0c2da 100644
+--- a/src/aatest.c
++++ b/src/aatest.c
+@@ -1,3 +1,5 @@
++#include <string.h> /* strcpy() */
++#include <stdlib.h> /* exit() */
+ #include "aalib.h"
+ int main(int argc, char **argv)
+ {
diff --git a/media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch b/media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch
new file mode 100644
index 000000000000..daf9cde9f575
--- /dev/null
+++ b/media-libs/aalib/files/aalib-1.4_rc5-tinfo.patch
@@ -0,0 +1,19 @@
+diff --git a/configure.ac b/configure.ac
+index 66bcbc0..f15f06e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -302,6 +302,14 @@ AC_DEFUN(AC_CURSES, [
+ if test "$curses_driver_test" = yes; then
+ if $search_ncurses
+ then
+ AC_CHECKING("location of curses")
++ PKG_CHECK_MODULES([CURSES], [ncurses], [
++ AC_MSG_RESULT([Found ncurses via pkg-config: CURSES_CFLAGS="$CURSES_CFLAGS" CURSES_LIBS="$CURSES_LIBS"])
++ CFLAGS="$CFLAGS $CURSES_CFLAGS"
++ LIBS="$LIBS $CURSES_LIBS"
++ AALIB_LIBS="$AALIB_LIBS $CURSES_LIBS"
++ search_ncurses=false
++ curses_driver=true
++ ], [])
+
+ AC_NCURSES(/usr/include, ncurses.h, , -I/usr/include/ncurses , "ncurses on /usr/include")
diff --git a/media-libs/aalib/metadata.xml b/media-libs/aalib/metadata.xml
new file mode 100644
index 000000000000..b89813c0f491
--- /dev/null
+++ b/media-libs/aalib/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>slyfox@gentoo.org</email>
+ <name>Sergei Trofimovich</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">aa-project</remote-id>
+ </upstream>
+</pkgmetadata>