summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Levine <plevine457@gmail.com>2017-10-07 17:39:00 -0400
committerAlexis Ballier <aballier@gentoo.org>2017-10-08 12:24:02 +0200
commit358d2b6e9d337e814e8027796e37f60947f34218 (patch)
treedc055caa2904a51f37009dbff06cef5fb3b50dbf /media-libs/avidemux-core/avidemux-core-2.6.20-r2.ebuild
parentmedia-video/ffmpeg: backport upstream patch to build with openjpeg 2.3; by An... (diff)
downloadgentoo-358d2b6e9d337e814e8027796e37f60947f34218.tar.gz
gentoo-358d2b6e9d337e814e8027796e37f60947f34218.tar.bz2
gentoo-358d2b6e9d337e814e8027796e37f60947f34218.zip
media-libs/avidemux-core: Revbump needed for PR-5835
Bug: https://bugs.gentoo.org/625930 Package-Manager: Portage-2.3.10, Repoman-2.3.3
Diffstat (limited to 'media-libs/avidemux-core/avidemux-core-2.6.20-r2.ebuild')
-rw-r--r--media-libs/avidemux-core/avidemux-core-2.6.20-r2.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/media-libs/avidemux-core/avidemux-core-2.6.20-r2.ebuild b/media-libs/avidemux-core/avidemux-core-2.6.20-r2.ebuild
new file mode 100644
index 000000000000..1fad3f21b9fc
--- /dev/null
+++ b/media-libs/avidemux-core/avidemux-core-2.6.20-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+DESCRIPTION="Core libraries for a video editor designed for simple cutting, filtering and encoding tasks"
+HOMEPAGE="http://fixounet.free.fr/avidemux"
+
+# Multiple licenses because of all the bundled stuff.
+LICENSE="GPL-1 GPL-2 MIT PSF-2 public-domain"
+SLOT="2.6"
+IUSE="debug nls nvenc sdl system-ffmpeg vaapi vdpau xv"
+
+if [[ ${PV} == *9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/mean00/avidemux2.git"
+ EGIT_CHECKOUT_DIR=${WORKDIR}
+
+ inherit git-r3
+else
+ MY_PN="${PN/-core/}"
+ MY_P="${MY_PN}_${PV}"
+ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_PN}/${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+# Trying to use virtual; ffmpeg misses aac,cpudetection USE flags now though, are they needed?
+DEPEND="
+ !<media-video/avidemux-${PV}:${SLOT}
+ dev-db/sqlite:3
+ sdl? ( media-libs/libsdl:0 )
+ system-ffmpeg? ( >=virtual/ffmpeg-9:0[mp3,theora] )
+ xv? ( x11-libs/libXv:0 )
+ vaapi? ( x11-libs/libva:0 )
+ vdpau? ( x11-libs/libvdpau:0 )
+ nvenc? ( media-video/nvidia_video_sdk )
+"
+RDEPEND="
+ $DEPEND
+ nls? ( virtual/libintl:0 )
+"
+DEPEND="
+ $DEPEND
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ !system-ffmpeg? ( dev-lang/yasm[nls=] )
+"
+
+S="${WORKDIR}/${MY_P}"
+CMAKE_USE_DIR="${S}/${PN/-/_}"
+
+PATCHES=("${FILESDIR}"/${P}-fix-cmake.patch )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if use system-ffmpeg ; then
+ # Preparations to support the system ffmpeg. Currently fails because it depends on files the system ffmpeg doesn't install.
+ local error="Failed to remove ffmpeg."
+
+ rm -rf cmake/admFFmpeg* cmake/ffmpeg* avidemux_core/ffmpeg_package buildCore/ffmpeg || die "${error}"
+ sed -i -e 's/include(admFFmpegUtil)//g' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e '/registerFFmpeg/d' avidemux/commonCmakeApplication.cmake || die "${error}"
+ sed -i -e 's/include(admFFmpegBuild)//g' avidemux_core/CMakeLists.txt || die "${error}"
+ fi
+}
+
+src_configure() {
+ # Add lax vector typing for PowerPC.
+ if use ppc || use ppc64 ; then
+ append-cflags -flax-vector-conversions
+ fi
+
+ # See bug 432322.
+ use x86 && replace-flags -O0 -O1
+
+ local mycmakeargs=(
+ -DAVIDEMUX_SOURCE_DIR='${S}'
+ -DGETTEXT="$(usex nls)"
+ -DSDL="$(usex sdl)"
+ -DLIBVA="$(usex vaapi)"
+ -DVDPAU="$(usex vdpau)"
+ -DXVIDEO="$(usex xv)"
+ -DNVENC="$(usex nvenc)"
+ )
+
+ if use debug ; then
+ mycmakeargs+=( -DVERBOSE=1 -DADM_DEBUG=1 )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile -j1
+}
+
+src_install() {
+ cmake-utils_src_install -j1
+}