summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2018-09-18 01:08:27 +0300
committerMart Raudsepp <leio@gentoo.org>2018-09-18 01:16:29 +0300
commitc92f40ae6d0a6264ce6db6317ea555f5e501ef35 (patch)
treefbb101e5ed584f53b974cbe1d25797e0c61e220e /media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.3.ebuild
parentdev-util/mingw64-runtime: cleanup old (diff)
downloadgentoo-c92f40ae6d0a6264ce6db6317ea555f5e501ef35.tar.gz
gentoo-c92f40ae6d0a6264ce6db6317ea555f5e501ef35.tar.bz2
gentoo-c92f40ae6d0a6264ce6db6317ea555f5e501ef35.zip
media-libs/gst-plugins-ugly: bump to 1.14.3, no code changes from 1.14.2
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.3.ebuild')
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.3.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.3.ebuild
new file mode 100644
index 000000000000..1b31266066c2
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.14.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="https://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2+" # some split plugins are LGPL but combining with a GPL library
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}