summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2018-08-14 13:29:55 -0700
committerMatt Turner <mattst88@gentoo.org>2018-08-14 13:31:55 -0700
commitc38db89c56279684dce2769dad09d23a4ed2cc8f (patch)
tree16c19e347daebccde4bef4af354b3888e123b3ea /media-libs/mesa
parentsys-apps/yarn: 1.9.4 bump (diff)
downloadgentoo-c38db89c56279684dce2769dad09d23a4ed2cc8f.tar.gz
gentoo-c38db89c56279684dce2769dad09d23a4ed2cc8f.tar.bz2
gentoo-c38db89c56279684dce2769dad09d23a4ed2cc8f.zip
media-libs/mesa: Default to classic i915
The new meson build system does not like it if you ask it to build both the classic and gallium versions of i915 and fails to configure. If both classic and gallium are enabled build only the classic i915 driver since it is better supported and supports more hardware. Closes: https://bugs.gentoo.org/663400
Diffstat (limited to 'media-libs/mesa')
-rw-r--r--media-libs/mesa/mesa-18.2.0_rc2.ebuild12
-rw-r--r--media-libs/mesa/mesa-9999.ebuild12
2 files changed, 16 insertions, 8 deletions
diff --git a/media-libs/mesa/mesa-18.2.0_rc2.ebuild b/media-libs/mesa/mesa-18.2.0_rc2.ebuild
index de26a3b43d21..592501bdb8e2 100644
--- a/media-libs/mesa/mesa-18.2.0_rc2.ebuild
+++ b/media-libs/mesa/mesa-18.2.0_rc2.ebuild
@@ -311,11 +311,15 @@ multilib_src_configure() {
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
- gallium_enable video_cards_i915 i915
gallium_enable video_cards_imx imx
- if ! use video_cards_i915 && \
- ! use video_cards_i965; then
- gallium_enable video_cards_intel i915
+
+ # Only one i915 driver (classic vs gallium). Default to classic.
+ if ! use classic; then
+ gallium_enable video_cards_i915 i915
+ if ! use video_cards_i915 && \
+ ! use video_cards_i965; then
+ gallium_enable video_cards_intel i915
+ fi
fi
gallium_enable video_cards_r300 r300
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 6d4fc7f23736..4bdf4c91e6f4 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -311,11 +311,15 @@ multilib_src_configure() {
gallium_enable video_cards_vivante etnaviv
gallium_enable video_cards_vmware svga
gallium_enable video_cards_nouveau nouveau
- gallium_enable video_cards_i915 i915
gallium_enable video_cards_imx imx
- if ! use video_cards_i915 && \
- ! use video_cards_i965; then
- gallium_enable video_cards_intel i915
+
+ # Only one i915 driver (classic vs gallium). Default to classic.
+ if ! use classic; then
+ gallium_enable video_cards_i915 i915
+ if ! use video_cards_i915 && \
+ ! use video_cards_i965; then
+ gallium_enable video_cards_intel i915
+ fi
fi
gallium_enable video_cards_r300 r300