summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-04-16 10:09:45 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-04-16 10:09:45 +0200
commit52a251e21442db7774712068cb809b2389827040 (patch)
tree47714d0b49e6a8393d3fea8c855e624fca108961 /media-libs/opus
parentmedia-sound/amsynth: bump to 1.13.3 (diff)
downloadgentoo-52a251e21442db7774712068cb809b2389827040.tar.gz
gentoo-52a251e21442db7774712068cb809b2389827040.tar.bz2
gentoo-52a251e21442db7774712068cb809b2389827040.zip
media-libs/opus: bump to 1.5.2
also removed runtime toggles from the ebuild as they are not in the meson file anymore Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-libs/opus')
-rw-r--r--media-libs/opus/Manifest1
-rw-r--r--media-libs/opus/opus-1.5.2.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/opus/Manifest b/media-libs/opus/Manifest
index 5a6cbf3839e0..6bf793ce7aa8 100644
--- a/media-libs/opus/Manifest
+++ b/media-libs/opus/Manifest
@@ -1,2 +1,3 @@
DIST opus-1.4.tar.gz 1063408 BLAKE2B 21f11df745cb868f4da1586d678901045fd9bd0c0590628015f3adc2522c88b0660df88096abe975051fec3188b76b93762c4a01907c2ab2b23c40fde79cf6ad SHA512 1ecd39e0add24de12823bf7c936bb67441228721e2cdae0edbfcf3cee0894bcc6edf2a1d0ca5cdfdad1565803bf39cc4c985ad32710c2a9582f850adeb5ca631
DIST opus-1.5.1.tar.gz 7834540 BLAKE2B 5ba1d6f28594f366b545507bafb22751e15a0e78e152e7cdef456dccb0bc9fc512faa18c90fb4ea5455a9535de89df987dea8a0fabce9a25c285d0c410d4b482 SHA512 fa66c5d753f5deb5d61d068ff8f633d8cb5f454c94aeee9c404023ebc483f9b350586cdd98b7013faf4df3193e170a1708aaa598914275f7bc8be07587cc4dc6
+DIST opus-1.5.2.tar.gz 7839412 BLAKE2B 1c54de8171df1da69b64a2eca4ce97a0280cfceafb387f40ef1186add366030a397fabc19b18cf1e50d6dbaccb027697d1e2b3da4fa6ab73d70c2b4e723e87f7 SHA512 78d963cd56d5504611f111e2b3606e236189a3585d65fae1ecdbec9bf4545632b1956f11824328279a2d1ea2ecf441ebc11e455fb598d20a458df15185e95da4
diff --git a/media-libs/opus/opus-1.5.2.ebuild b/media-libs/opus/opus-1.5.2.ebuild
new file mode 100644
index 000000000000..d26bfda3e5d1
--- /dev/null
+++ b/media-libs/opus/opus-1.5.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit flag-o-matic meson-multilib python-any-r1
+
+DESCRIPTION="Open codec for interactive speech and music transmission over the Internet"
+HOMEPAGE="https://opus-codec.org/"
+SRC_URI="https://downloads.xiph.org/releases/opus/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+INTRINSIC_FLAGS="cpu_flags_x86_sse cpu_flags_arm_neon"
+IUSE="custom-modes debug doc hardened static-libs test ${INTRINSIC_FLAGS}"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? (
+ app-text/doxygen
+ media-gfx/graphviz
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.1-libdir-macro.patch
+ "${FILESDIR}"/${PN}-1.4-arm64-neon.patch
+)
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(multilib_native_usex static-libs both shared)
+
+ $(meson_use custom-modes)
+ $(meson_feature test tests)
+ $(meson_use debug assertions)
+ $(meson_use hardened hardening)
+
+ $(meson_native_use_feature doc docs)
+
+ -Ddocdir="${EPREFIX}"/usr/share/doc/${PF}
+ )
+
+ # Disable intrinsics if no flags are enabled (bug #752069)
+ # bug #752069
+ # TODO: What is -Dasm for?
+ local i
+ for i in ${INTRINSIC_FLAGS} ; do
+ use ${i} && emesonargs+=( -Dintrinsics=enabled ) && break
+ done || emesonargs+=( -Dintrinsics=disabled )
+
+ if is-flagq -ffast-math || is-flagq -Ofast ; then
+ emesonargs+=( -Dfloat-approx=true )
+ fi
+
+ meson_src_configure
+}
+
+multilib_src_test() {
+ meson_src_test --timeout-multiplier=2
+}