summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/oyranos/oyranos-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/oyranos/oyranos-9999.ebuild')
-rw-r--r--media-libs/oyranos/oyranos-9999.ebuild102
1 files changed, 102 insertions, 0 deletions
diff --git a/media-libs/oyranos/oyranos-9999.ebuild b/media-libs/oyranos/oyranos-9999.ebuild
new file mode 100644
index 000000000000..faf149296fe6
--- /dev/null
+++ b/media-libs/oyranos/oyranos-9999.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic git-r3 cmake-utils cmake-multilib
+
+DESCRIPTION="Colour management system allowing to share various settings across applications and services"
+HOMEPAGE="http://www.oyranos.org/"
+EGIT_REPO_URI="https://github.com/${PN}-cms/${PN}.git"
+
+KEYWORDS=""
+LICENSE="BSD"
+SLOT="0"
+IUSE="X cairo cups doc exif fltk jpeg qt4 qt5 raw test tiff"
+
+#OY_LINGUAS="cs;de;eo;eu;fr;ru" #TODO
+
+COMMON_DEPEND="
+ || (
+ =app-admin/elektra-0.7*:0[${MULTILIB_USEDEP}]
+ >=app-admin/elektra-0.8.4:0[${MULTILIB_USEDEP}]
+ )
+ >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]
+ >=dev-libs/yajl-2.0.4-r1[${MULTILIB_USEDEP}]
+ >=media-libs/lcms-2.5:2[${MULTILIB_USEDEP}]
+ >=media-libs/libpng-1.6.10:0[${MULTILIB_USEDEP}]
+ >=media-libs/libXcm-0.5.3[${MULTILIB_USEDEP}]
+ cairo? ( >=x11-libs/cairo-1.12.14-r4[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.7.1-r1[${MULTILIB_USEDEP}] )
+ exif? ( >=media-gfx/exiv2-0.23-r2:=[${MULTILIB_USEDEP}] )
+ fltk? ( x11-libs/fltk:1 )
+ jpeg? ( virtual/jpeg:0[${MULTILIB_USEDEP}] )
+ qt5? (
+ dev-qt/qtgui:5 dev-qt/qtwidgets:5 dev-qt/qtx11extras:5
+ )
+ !qt5? (
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
+ )
+ raw? ( >=media-libs/libraw-0.15.4[${MULTILIB_USEDEP}] )
+ tiff? ( media-libs/tiff:0[${MULTILIB_USEDEP}] )
+ X? ( >=x11-libs/libXfixes-5.0.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}]
+ >=x11-libs/libXinerama-1.1.3[${MULTILIB_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/icc-profiles-basiccolor-printing2009
+ media-libs/icc-profiles-openicc"
+
+DOCS=( AUTHORS.md ChangeLog.md README.md )
+RESTRICT="test"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/oyranos-config
+)
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/oyranos/oyranos_version.h
+)
+
+CMAKE_REMOVE_MODULES_LIST="${CMAKE_REMOVE_MODULES_LIST} FindFltk FindXcm FindCUPS"
+
+src_prepare() {
+ einfo remove bundled libs
+ rm -rf elektra* yajl || die
+
+ if use fltk ; then
+ #src/examples does not include fltk flags
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags)
+ fi
+
+ cmake-utils_src_prepare
+}
+
+multilib_src_configure() {
+ local libdir=$(get_libdir)
+ local mycmakeargs=(
+ -DLIB_SUFFIX=${libdir#lib}
+ -DUSE_SYSTEM_ELEKTRA=YES
+ -DUSE_SYSTEM_YAJL=YES
+ -DUSE_Qt4=$(usex '!qt5')
+ -DCMAKE_DISABLE_FIND_PACKAGE_Cairo=$(usex '!cairo')
+ -DCMAKE_DISABLE_FIND_PACKAGE_Cups=$(usex '!cups')
+ -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen=$(usex '!doc')
+ -DCMAKE_DISABLE_FIND_PACKAGE_Exif2=$(usex '!exif')
+ -DCMAKE_DISABLE_FIND_PACKAGE_JPEG=$(usex '!jpeg')
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibRaw=$(usex '!raw')
+ -DCMAKE_DISABLE_FIND_PACKAGE_TIFF=$(usex '!tiff')
+ -DCMAKE_DISABLE_FIND_PACKAGE_X11=$(usex '!X')
+ -DCMAKE_DISABLE_FIND_PACKAGE_Fltk=$(multilib_native_usex fltk OFF ON)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt4=$(multilib_native_usex qt4 OFF ON)
+ -DCMAKE_DISABLE_FIND_PACKAGE_Qt5=$(multilib_native_usex qt5 OFF ON)
+ )
+
+ cmake-utils_src_configure
+}