summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Pihl <ahvenas@gmail.com>2020-07-03 12:50:31 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-07-11 11:18:37 +0300
commitc9bd97ea9d816275176a276e578a994fdecc2377 (patch)
tree8f0726783ddf3eed6d91b2b3d3b167067a9a7df1 /media-libs
parentapp-misc/physlock: Use upstream PAM config (diff)
downloadgentoo-c9bd97ea9d816275176a276e578a994fdecc2377.tar.gz
gentoo-c9bd97ea9d816275176a276e578a994fdecc2377.tar.bz2
gentoo-c9bd97ea9d816275176a276e578a994fdecc2377.zip
media-libs/webvfx: Version bump to 1.2.0
Closes: https://bugs.gentoo.org/717560 Signed-off-by: Henrik Pihl <ahvenas@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/webvfx/Manifest1
-rw-r--r--media-libs/webvfx/webvfx-1.2.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/media-libs/webvfx/Manifest b/media-libs/webvfx/Manifest
index 70d207c06ffe..a982cf1cf3c6 100644
--- a/media-libs/webvfx/Manifest
+++ b/media-libs/webvfx/Manifest
@@ -1 +1,2 @@
DIST webvfx-1.1.0.txz 1163312 BLAKE2B a948c967ee8a21f91086b76ac2737a855d6a6a0c576471d9844a7587ee45c8f42553b57b8f5e989dae696924e67c341317c541eef87f28e9a49ff25e8e0aed29 SHA512 f88726ef8ae779f238fe6b784bc53ef47ef67a8d7b524f2c465fdf5de57f37bd388d81ac52b0a7abc30a1c836f801a8b9df0ef183e2507b229dd6431d38c8768
+DIST webvfx-1.2.0.txz 1178880 BLAKE2B 7ef08f791b291897f39e170f0572db2fb98c78bced9ed3560b1b94cfe48bedf0af3af5e57381bd039f6cf3dc1d558fb07a6a959b28f1c6a380d0dd0f1bfc64fd SHA512 84473df90553d2d85e1860eb98326fc65ebca02f1cbd8415b83e02ea032442d2aa42c000e366b6ca217bb59526b2b4409d85b169cc7e60d86443b79a1ff5614a \ No newline at end of file
diff --git a/media-libs/webvfx/webvfx-1.2.0.ebuild b/media-libs/webvfx/webvfx-1.2.0.ebuild
new file mode 100644
index 000000000000..fe34f6aaf160
--- /dev/null
+++ b/media-libs/webvfx/webvfx-1.2.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic qmake-utils toolchain-funcs
+
+DESCRIPTION="Video effects library based on web technologies"
+HOMEPAGE="https://github.com/mltframework/webvfx/"
+SRC_URI="https://github.com/mltframework/${PN}/releases/download/1.2.0/${P}.txz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+BDEPEND="
+ doc? ( app-doc/doxygen )
+"
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtwebkit:5
+ dev-qt/qtwidgets:5
+ media-libs/mlt
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-qt/qtnetwork:5
+"
+
+src_prepare() {
+ default
+
+ find -name "*.pro" -exec \
+ sed -i -e "s/\(system.*\)pkg-config/\1$(tc-getPKG_CONFIG)/" {} + || die
+
+ sed -i -e "s/\(target.*path.*PREFIX.*\)lib/\1$(get_libdir)/" \
+ webvfx/webvfx.pro || die
+
+ sed -i -e "s/PROJECT_NUMBER=\`.*\`/PROJECT_NUMBER=${PV}/" \
+ all.pro || die
+}
+
+src_configure() {
+ append-cxxflags -Wno-deprecated-declarations
+
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_compile() {
+ emake
+ use doc && emake doxydoc
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ use doc && local HTML_DOCS=( doxydoc/. )
+ einstalldocs
+}