summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-06-07 09:27:57 +0200
committerThomas Beierlein <tomjbe@gentoo.org>2024-06-07 09:30:03 +0200
commitbc59cfeb155f1279badf3be5cfe8451627e6720a (patch)
tree7d645d02ebbd88d2a6638b7b5ed787a1b8738644 /media-radio
parentapp-text/mdbook: Stabilize 0.4.40 sparc, #933618 (diff)
downloadgentoo-bc59cfeb155f1279badf3be5cfe8451627e6720a.tar.gz
gentoo-bc59cfeb155f1279badf3be5cfe8451627e6720a.tar.bz2
gentoo-bc59cfeb155f1279badf3be5cfe8451627e6720a.zip
media-radio/gpredict: add 2.3_p20231224, 9999
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'media-radio')
-rw-r--r--media-radio/gpredict/Manifest1
-rw-r--r--media-radio/gpredict/gpredict-2.3_p20231224.ebuild49
-rw-r--r--media-radio/gpredict/gpredict-9999.ebuild49
3 files changed, 99 insertions, 0 deletions
diff --git a/media-radio/gpredict/Manifest b/media-radio/gpredict/Manifest
index a2caf4e561f8..91ae4a91c101 100644
--- a/media-radio/gpredict/Manifest
+++ b/media-radio/gpredict/Manifest
@@ -1 +1,2 @@
DIST gpredict-2.3.tar.gz 7742902 BLAKE2B 1ff567871838b062c59ab0076330a354afee082506044f5ce2ae1c7553e7f3462770f7134d13e3b603f7966476d13b365dd3575cc6c7e32d23865ba29b602cc9 SHA512 d7434aff482c943951a79cb607c91f118cfbde8209b4b370d0d2147766244fab2839b5c712864c2c521635f31c484ef2bfd3c771371e946f5a3561801ab474b5
+DIST gpredict-2.3_p20231224.tar.gz 7719540 BLAKE2B 3febc18a5e69075b8345b695f4286cefb5ee56ae14fee53ff0a3add729e7f03a42626b94bb51d09a8f792c7a8da46a697f0e9f98f6f5cd12a8080369bf2a131d SHA512 e4299eb1b23629f08945a6b0ddfac2d6e78d3588297db441d0440ef714c4daf044fbacfb071c3b9c7f66227053ec27ae94f770f73ee3b352f820c959e657bb6a
diff --git a/media-radio/gpredict/gpredict-2.3_p20231224.ebuild b/media-radio/gpredict/gpredict-2.3_p20231224.ebuild
new file mode 100644
index 000000000000..2d7252dff97a
--- /dev/null
+++ b/media-radio/gpredict/gpredict-2.3_p20231224.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/csete/gpredict.git"
+else
+ COMMIT="098e3768240c7f5a169930a2660a23c9f42b37d6"
+ SRC_URI="https://github.com/csete/gpredict/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/goocanvas:2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+PATCHES=(
+ # remove wrong doc location
+ "${FILESDIR}/${PN}-2.3-doc.patch"
+ "${FILESDIR}/${PN}-2.3-gethostbyname.patch"
+)
+
+src_prepare() {
+ default
+ # prepare Version info
+ if [[ ${PV} != "9999" ]]; then
+ echo "${PV}" > "${S}"/.tarball-version
+ fi
+ eautoreconf
+}
diff --git a/media-radio/gpredict/gpredict-9999.ebuild b/media-radio/gpredict/gpredict-9999.ebuild
new file mode 100644
index 000000000000..2d7252dff97a
--- /dev/null
+++ b/media-radio/gpredict/gpredict-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/csete/gpredict.git"
+else
+ COMMIT="098e3768240c7f5a169930a2660a23c9f42b37d6"
+ SRC_URI="https://github.com/csete/gpredict/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT}"
+ KEYWORDS="~amd64 ~ppc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gdk-pixbuf[jpeg]
+ x11-libs/gtk+:3
+ x11-libs/goocanvas:2.0
+ net-misc/curl"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS NEWS README )
+
+PATCHES=(
+ # remove wrong doc location
+ "${FILESDIR}/${PN}-2.3-doc.patch"
+ "${FILESDIR}/${PN}-2.3-gethostbyname.patch"
+)
+
+src_prepare() {
+ default
+ # prepare Version info
+ if [[ ${PV} != "9999" ]]; then
+ echo "${PV}" > "${S}"/.tarball-version
+ fi
+ eautoreconf
+}