summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/denemo/denemo-0.9.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/denemo/denemo-0.9.6.ebuild')
-rw-r--r--media-sound/denemo/denemo-0.9.6.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/media-sound/denemo/denemo-0.9.6.ebuild b/media-sound/denemo/denemo-0.9.6.ebuild
new file mode 100644
index 000000000000..a1d6181ffdf0
--- /dev/null
+++ b/media-sound/denemo/denemo-0.9.6.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils fdo-mime
+
+DESCRIPTION="A music notation editor"
+HOMEPAGE="http://www.denemo.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa jack +fluidsynth nls +portaudio portmidi"
+
+COMMON_DEPEND="
+ >=app-text/evince-3
+ dev-libs/libxml2:2
+ >=dev-scheme/guile-1.8
+ gnome-base/librsvg:2
+ >=media-libs/libsmf-1.3
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ alsa? ( media-libs/alsa-lib )
+ jack? ( >=media-sound/jack-audio-connection-kit-0.102 )
+ fluidsynth? ( media-sound/fluidsynth )
+ portaudio? (
+ media-libs/portaudio
+ media-libs/aubio
+ sci-libs/fftw:3.0
+ media-libs/libsamplerate
+ )
+ portmidi? ( media-libs/portmidi )"
+RDEPEND="${COMMON_DEPEND}
+ media-sound/lilypond"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS ChangeLog doc/{DESIGN{,.lilypond},GOALS,TODO} NEWS )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-desktop.patch
+ epatch "${FILESDIR}"/${P}-alsa.patch
+ epatch "${FILESDIR}"/${P}-jack.patch
+ epatch "${FILESDIR}"/${P}-implicit-declarations.patch
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-gtk3 \
+ $(use_enable alsa) \
+ $(use_enable fluidsynth) \
+ $(use_enable jack) \
+ $(use_enable nls) \
+ $(use_enable portaudio) \
+ $(use_enable portmidi)
+}
+
+pkg_postinst() { fdo-mime_desktop_database_update; }
+pkg_postrm() { fdo-mime_desktop_database_update; }