summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2019-08-14 15:32:05 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-08-17 18:34:41 +0300
commit46af22f0c24778870b6f2a4f52702c1e9a32fe38 (patch)
tree1afe283e85739a1b7288d9d055f37131b934b585 /media-sound/denemo
parentdev-db/myodbc: bump to v8.0.17 (diff)
downloadgentoo-46af22f0c24778870b6f2a4f52702c1e9a32fe38.tar.gz
gentoo-46af22f0c24778870b6f2a4f52702c1e9a32fe38.tar.bz2
gentoo-46af22f0c24778870b6f2a4f52702c1e9a32fe38.zip
media-sound/denemo: bump to version 2.3.0
- bump to EAPI=7 - inherit xdg instead of xdg-utils - rename doc USE flag to gtk-doc - add subslot modifier for media-libs/aubio and media-sound/fluidsynth The bug below blocks this update for multilib machines and needs to be merged first! Bug: https://bugs.gentoo.org/691274 Closes: https://bugs.gentoo.org/691920 Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/12704 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-sound/denemo')
-rw-r--r--media-sound/denemo/Manifest1
-rw-r--r--media-sound/denemo/denemo-2.3.0.ebuild122
-rw-r--r--media-sound/denemo/files/denemo-2.3.0-0001-configure.ac-patch-to-find-guile-2.2.patch80
3 files changed, 203 insertions, 0 deletions
diff --git a/media-sound/denemo/Manifest b/media-sound/denemo/Manifest
index ea8a1e532966..43707e3a159b 100644
--- a/media-sound/denemo/Manifest
+++ b/media-sound/denemo/Manifest
@@ -1 +1,2 @@
DIST denemo-2.2.0.tar.gz 17032009 BLAKE2B 66732fcdaa5d5119ca2a45e5a8c6829e05092a4f0e18e3c8a991bddaaf863ea05889654af47150650d2c67397afa957de0fc3ce0ada86a22be00ae91d4add993 SHA512 74bef7b888abd86db42cee7ecb404e1b9211f9965207366c99980137194acd2afa6ec8b1c18da8a12fe4c6951d8a1bb873b313f5749ea629bb7eaeedf12368ef
+DIST denemo-2.3.0.tar.gz 17322118 BLAKE2B b15d0d7b01b50c903c0f2064198fdf258a84a63965c7ed09e8d146f2c35581bca8f62ee4e212579fe8811099e49dde33e32045b7af6c542d98e9193a6a81bf5b SHA512 dbfbe25e0e6c7bbdb3e96d6a31dab3409937451738644ff199d075d7c647b0c88ee8cb61efb71b03aea72fe80780665871962f0ea1aa152e704040d03833604f
diff --git a/media-sound/denemo/denemo-2.3.0.ebuild b/media-sound/denemo/denemo-2.3.0.ebuild
new file mode 100644
index 000000000000..6bc0a16e9940
--- /dev/null
+++ b/media-sound/denemo/denemo-2.3.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools xdg
+
+DESCRIPTION="A music notation editor"
+HOMEPAGE="http://www.denemo.org/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+ OFL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# configure options currently not used:
+# --enable-mem(no) memory debugging: needs Electric fence (efence), which
+# is not available in portage. See https://github.com/boundarydevices/efence
+# --enable-gtk-doc-pdf(no) doesn't work
+IUSE="alsa +aubio debug +evince jack +fluidsynth gtk-doc +gtk3 nls +portaudio
+ +portmidi +rubberband static test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2:2
+ >=dev-scheme/guile-2:12=
+ gnome-base/librsvg:2
+ media-libs/fontconfig:1.0
+ >=media-libs/libsmf-1.3
+ >=media-libs/libsndfile-1.0.28-r1
+ >=media-sound/lilypond-2.19.54[guile2]
+ alsa? ( >=media-libs/alsa-lib-1.1.2 )
+ aubio? ( >=media-libs/aubio-0.4.1-r1:= )
+ evince? ( >=app-text/evince-3.22.1-r1:= )
+ fluidsynth? ( >=media-sound/fluidsynth-1.1.6-r1:= )
+ gtk3? (
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0=
+ )
+ !gtk3? (
+ x11-libs/gtk+:2
+ x11-libs/gtksourceview:2.0
+ )
+ jack? ( virtual/jack )
+ portaudio? (
+ >=media-libs/portaudio-19_pre20140130
+ sci-libs/fftw:3.0=
+ )
+ portmidi? ( >=media-libs/portmidi-217-r1 )
+ rubberband? ( >=media-libs/rubberband-1.8.1-r1 )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ >=dev-util/intltool-0.51.0-r1
+ >=sys-devel/flex-2.6.1
+ virtual/pkgconfig
+ virtual/yacc
+ gtk-doc? ( >=dev-util/gtk-doc-1.25-r1 )
+ nls? ( >=sys-devel/gettext-0.19.8.1 )
+"
+
+REQUIRED_USE="
+ evince? ( gtk3 )
+"
+
+DOCS=( AUTHORS ChangeLog docs/{DESIGN{,.lilypond},GOALS,TODO} NEWS )
+
+PATCHES=(
+ "${FILESDIR}/${P}-0001-configure.ac-patch-to-find-guile-2.2.patch"
+)
+
+src_prepare() {
+ sed -e '/^Categories=/s/GNOME\;/GNOME\;GTK\;/' -i pixmaps/denemo.desktop || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --disable-gtk-doc-pdf
+ --disable-installed-tests
+ --disable-mem
+ --disable-rpath
+ --enable-x11
+ $(use_enable alsa)
+ $(use_enable aubio)
+ # --enable-doc does nothing for itself
+ # basic html documentation is always being installed in the
+ # /usr/share/denemo/manual directory
+ $(use_enable gtk-doc doc)
+ $(use_enable gtk-doc gtk-doc)
+ $(use_enable gtk-doc gtk-doc-html)
+ $(use_enable evince)
+ $(use_enable fluidsynth)
+ $(use_enable jack)
+ $(use_enable nls)
+ $(use_enable portaudio)
+ $(use_enable portmidi)
+ $(use_enable rubberband)
+ $(use_enable static)
+ $(usex gtk3 --enable-gtk3 --enable-gtk2)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ # make check fails if used with parallel builds
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ # link html documentation installed in /usr/share/denemo/manual
+ dodir /usr/share/doc/${PF}/html
+ local f
+ for f in denemo-manual.html denemo.css images; do
+ dosym ../../../denemo/manual/"${f}" /usr/share/doc/${PF}/html/"${f}"
+ done
+}
diff --git a/media-sound/denemo/files/denemo-2.3.0-0001-configure.ac-patch-to-find-guile-2.2.patch b/media-sound/denemo/files/denemo-2.3.0-0001-configure.ac-patch-to-find-guile-2.2.patch
new file mode 100644
index 000000000000..982ccfade868
--- /dev/null
+++ b/media-sound/denemo/files/denemo-2.3.0-0001-configure.ac-patch-to-find-guile-2.2.patch
@@ -0,0 +1,80 @@
+From 9a515060df9024ef64bce2055fd3f2ceada5efa8 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Wed, 14 Aug 2019 13:51:32 +0200
+Subject: [PATCH] configure.ac: patch to find guile-2.2
+
+The patch uses the GUILE_PKG command to find any installed
+version of guile instead of explicitly checking for guile-1.8
+and guile-2.0 but missing guile-2.2.
+This patch was already provided to upstream with denemo-2.2, but
+didn't yet get accepted due to not being able to compile the
+Windows version with this patch (cf. http://savannah.gnu.org/bugs/?54821)
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ configure.ac | 41 +++--------------------------------------
+ 1 file changed, 3 insertions(+), 38 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f85b74e..1fc0af0 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -30,7 +30,10 @@ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_YACC
+ AM_PROG_LEX
++GUILE_PKG
+ GUILE_FLAGS
++CFLAGS="$CFLAGS $GUILE_CFLAGS"
++LIBS="$LIBS $GUILE_LIBS"
+
+ AC_PROG_LIBTOOL
+
+@@ -63,44 +66,6 @@ AS_COMPILER_FLAG([-fdiagnostics-color=auto],
+
+ AM_CONDITIONAL(ENABLE_GLIB_TEST, [test "x$enable_glibtest" = "xyes"])
+
+-AC_ARG_ENABLE(
+- guile_1_8,
+- AS_HELP_STRING([--enable-guile_1_8], [use GUILE_1_8 @<:@default=no@:>@]),
+- [
+- if test "x$enableval" != "xno"; then
+- useguile_1_8=yes
+- PKG_CHECK_MODULES(GUILE_1_8, guile-1.8 >= 1.8)
+- LIBS="$LIBS $GUILE_1_8_LIBS"
+- CFLAGS="$CFLAGS $GUILE_1_8_CFLAGS"
+- fi
+- ], [ useguile_1_8=no ])
+-
+-AC_ARG_ENABLE(
+- guile_2_0,
+- AS_HELP_STRING([--enable-guile_2_0], [use GUILE_2_0 @<:@default=no@:>@]),
+- [
+- if test "x$enableval" != "xno"; then
+- useguile_2_0=yes
+- PKG_CHECK_MODULES(GUILE_2, guile-2.0 >= 2.0)
+- LIBS="$LIBS $GUILE_2_LIBS"
+- CFLAGS="$CFLAGS $GUILE_2_CFLAGS"
+- fi
+- ], [ useguile_2_0=no ])
+-
+-if [test "x$useguile_1_8" = "xno"] && [test "x$useguile_2_0" = "xno"]; then
+- PKG_CHECK_MODULES([GUILE_2], [guile-2.0], useguile_2_0=yes, useguile_2_0=no)
+- LIBS="$LIBS $GUILE_2_LIBS"
+- CFLAGS="$CFLAGS $GUILE_2_CFLAGS"
+- if test "x$useguile_2_0" = "xno"; then
+- PKG_CHECK_MODULES(GUILE_1_8, guile-1.8 >= 1.8)
+- LIBS="$LIBS $GUILE_1_8_LIBS"
+- CFLAGS="$CFLAGS $GUILE_1_8_CFLAGS"
+- useguile_1_8=yes
+- else
+- useguile_2_0=yes
+- fi
+-fi
+-
+ PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.30])
+ CFLAGS="$CFLAGS $GLIB_CFLAGS"
+ LIBS="$LIBS $GLIB_LIBS"
+--
+2.22.0
+