summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2018-11-23 21:00:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-25 00:16:42 +0100
commitb30fa91ef71d9e6c41f22118b4cee1999b403357 (patch)
tree0fd5c918fe8249eecac2643c5c08d238071e7197 /media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild
parentx11-themes/qtcurve: Drop 1.9.0_rc1-r2 (diff)
downloadgentoo-b30fa91ef71d9e6c41f22118b4cee1999b403357.tar.gz
gentoo-b30fa91ef71d9e6c41f22118b4cee1999b403357.tar.bz2
gentoo-b30fa91ef71d9e6c41f22118b4cee1999b403357.zip
media-sound/jack-smf-utils: EAPI-7 bump, DEPEND on virtual/jack
- Drop version specifier from dev-libs/glib dependency. - Sort dependencies. - Update HOMEPAGE and SRC_URI. The old ones are no longer reachable, and it looks like the project is now hosted on SourceForge. Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Karl Linden <karl.j.linden@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10440 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild')
-rw-r--r--media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild b/media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild
new file mode 100644
index 000000000000..edaef45d9e2c
--- /dev/null
+++ b/media-sound/jack-smf-utils/jack-smf-utils-1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utilities for MIDI streams and files using Jack MIDI"
+HOMEPAGE="https://sourceforge.net/projects/jack-smf-utils/"
+SRC_URI="https://sourceforge.net/projects/jack-smf-utils/files/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lash readline"
+
+RDEPEND="
+ dev-libs/glib
+ virtual/jack
+ lash? ( media-sound/lash )
+ readline? ( sys-libs/readline:0 )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with lash) \
+ $(use_with readline)
+}