summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/lastfmplayer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/lastfmplayer')
-rw-r--r--media-sound/lastfmplayer/Manifest3
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch50
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-glib.h.patch16
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-extensions-path.patch44
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r3.ebuild137
-rw-r--r--media-sound/lastfmplayer/metadata.xml5
6 files changed, 255 insertions, 0 deletions
diff --git a/media-sound/lastfmplayer/Manifest b/media-sound/lastfmplayer/Manifest
new file mode 100644
index 000000000000..f08ef72c9396
--- /dev/null
+++ b/media-sound/lastfmplayer/Manifest
@@ -0,0 +1,3 @@
+DIST dbusextension-2.0.tar.bz2 11101 SHA256 db9f5040b593886a36ec409bb1e5b96f2225132207c841cc0b3c15c6242741d2 SHA512 f277a8e4452f2d80b93111ef956f54999881d44df6beaf4294a8dc9468c5f6c2660bbd34f7d363c0541e2f46078fd6ab311b6d30547f5369fe84be1045f849f8 WHIRLPOOL e2c8aef7e8112fb3959f653a53861da5ba77f57c33ea4cafe157f8e060e98362acd8220602bc2ffae7c9437526df902fd10c5c5b5f4175bcbc9c2b1bddc988e5
+DIST lastfm-1.5.4.27091+dfsg.tar.gz 1480448 SHA256 b26596f35e71c9f5b20505486cb73f34404bbef01949c166929f566a5d9d6505 SHA512 72506c942217973fc170c2f37bf3a91fbd6378e626d891913aefa6bf7fcfa96751e2fb7c048405d7f1aad18bc9121bf066afb78b1a2498172af59d03fd80493b WHIRLPOOL 8da1761606cc50a0b17f77694b1ab8ab8c26d55eb8dd8abcc10c23afd3256f802c935d499db48614379f45f72ef754e0d00b65ca59091e58a84ff355b40e8c8a
+DIST lastfm_1.5.4.27091+dfsg-2.debian.tar.gz 69004 SHA256 e5953574db35c098b0d82537d69c0e15369bd3d3a84920a7ae42948ce9d42db7 SHA512 ef4f9995681f77ff8751d1d4d28bb68f5640b54f9646c79fafc53b3d20ba155b60baca29047ebe01f01919c89d2bfb1aeee573aa2946ac382c6de984eb81f923 WHIRLPOOL 2df70e0112bec474f010785b36ce6a0575d07aaa9c38dcd27cefcabce2394fbecb8406b0674469805c9509620ddb64cb1623c602e26cd5521ead23951d2c4978
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch b/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch
new file mode 100644
index 000000000000..5a6009b21859
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-gcc47.patch
@@ -0,0 +1,50 @@
+Description: Fix compilation with gcc 4.7
+Author: John Stamp <jstamp@users.sourceforge.net>
+http://bugs.debian.org/667236
+https://bugs.gentoo.org/show_bug.cgi?id=423221
+--- a/src/libUnicorn/UnicornCommon.cpp
++++ b/src/libUnicorn/UnicornCommon.cpp
+@@ -32,6 +32,8 @@
+ #ifdef WIN32
+ #include <windows.h>
+ #include <shlobj.h>
++#else
++ #include <unistd.h>
+ #endif
+
+ using namespace std;
+--- a/src/lastfmapplication.cpp
++++ b/src/lastfmapplication.cpp
+@@ -59,6 +59,8 @@
+
+ #ifdef WIN32
+ #include <windows.h>
++#else
++ #include <unistd.h>
+ #endif
+
+ #ifdef Q_WS_MAC
+--- a/src/libUnicorn/Settings.h
++++ b/src/libUnicorn/Settings.h
+@@ -105,7 +105,7 @@
+ public:
+ MyQSettings( const UserSettings* const s )
+ {
+- beginGroup( s->username() );
++ this->beginGroup( s->username() );
+ }
+ };
+
+--- a/src/playerlistener.cpp
++++ b/src/playerlistener.cpp
+@@ -33,6 +33,10 @@
+ #include <iostream>
+ #include <algorithm>
+
++#ifdef Q_OS_UNIX
++ #include <unistd.h>
++#endif
++
+ using namespace std;
+
+
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-glib.h.patch b/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-glib.h.patch
new file mode 100644
index 000000000000..146fd1b361b1
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-1.5.4.27091-glib.h.patch
@@ -0,0 +1,16 @@
+ src/mediadevices/ipod/IpodDevice.cpp | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/src/mediadevices/ipod/IpodDevice.cpp b/src/mediadevices/ipod/IpodDevice.cpp
+index 3e40672..f3bad0e 100644
+--- a/src/mediadevices/ipod/IpodDevice.cpp
++++ b/src/mediadevices/ipod/IpodDevice.cpp
+@@ -35,7 +35,7 @@
+ extern "C"
+ {
+ #include <gpod/itdb.h>
+- #include <glib/glist.h>
++ #include <glib.h>
+ }
+
+ #define TABLE_NAME "IpodDeviceTracks"
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-extensions-path.patch b/media-sound/lastfmplayer/files/lastfmplayer-extensions-path.patch
new file mode 100644
index 000000000000..6805dd0eb7ea
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-extensions-path.patch
@@ -0,0 +1,44 @@
+Index: lastfm-1.5.4.27091+dfsg/definitions.pro.inc
+===================================================================
+--- lastfm-1.5.4.27091+dfsg.orig/definitions.pro.inc
++++ lastfm-1.5.4.27091+dfsg/definitions.pro.inc
+@@ -10,7 +10,7 @@ CONFIG( service ) {
+ CONFIG += plugin
+
+ win32: DESTDIR = $$BIN_DIR
+- else: DESTDIR = $$BIN_DIR/services
++ else: DESTDIR = $$BIN_DIR/lastfm_services
+
+ TARGET = srv_$$TARGET
+ }
+@@ -19,7 +19,7 @@ CONFIG( extension ) {
+ CONFIG += plugin
+
+ win32: DESTDIR = $$BIN_DIR
+- else: DESTDIR = $$BIN_DIR/extensions
++ else: DESTDIR = $$BIN_DIR/lastfm_services/extensions
+
+ TARGET = ext_$$TARGET
+ }
+Index: lastfm-1.5.4.27091+dfsg/src/libMoose/MooseCommon.cpp
+===================================================================
+--- lastfm-1.5.4.27091+dfsg.orig/src/libMoose/MooseCommon.cpp
++++ lastfm-1.5.4.27091+dfsg/src/libMoose/MooseCommon.cpp
+@@ -112,7 +112,7 @@ servicePath( QString name )
+ // Hack to get it working with VS2005
+ dirPath = qApp->applicationDirPath();
+ #else
+- dirPath = qApp->applicationDirPath() + "/services";
++ dirPath = "/usr/lib/lastfm_services";
+ #endif
+
+ #ifndef QT_NO_DEBUG
+@@ -358,7 +358,7 @@ extensionPaths()
+ // Hack to get it working with VS2005
+ QString path = qApp->applicationDirPath();
+ #else
+- QString path = qApp->applicationDirPath() + "/extensions";
++ QString path = "/usr/lib/lastfm_services/extensions";
+ #endif
+
+ #ifndef QT_NO_DEBUG
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r3.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r3.ebuild
new file mode 100644
index 000000000000..df62dd85cba5
--- /dev/null
+++ b/media-sound/lastfmplayer/lastfmplayer-1.5.4.27091-r3.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib readme.gentoo toolchain-funcs qt4-r2
+
+MY_P="${P/lastfmplayer/lastfm}+dfsg"
+
+DESCRIPTION="A player for last.fm radio streams"
+HOMEPAGE="http://www.last.fm/help/player
+ http://www.mehercule.net/staticpages/index.php/lastfm"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/lastfm-${PV}+dfsg.tar.gz
+ http://dev.gentoo.org/~hwoarang/distfiles/lastfm_${PV}+dfsg-2.debian.tar.gz
+ dbus? ( http://glue.umd.edu/~rossatok/dbusextension-2.0.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="dbus ipod"
+
+RDEPEND="dev-qt/qtgui:4
+ dev-qt/qtsql:4
+ media-libs/libsamplerate
+ sci-libs/fftw
+ media-libs/libmad
+ ipod? ( >=media-libs/libgpod-0.5.2 )
+ media-libs/alsa-lib"
+DEPEND="${RDEPEND}
+ app-arch/sharutils"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="To use the Last.fm player with a mozilla based browser:
+1. Install gnome-base/gconf
+2. gconftool-2 -t string -s /desktop/gnome/url-handlers/lastfm/command \"/usr/bin/lastfm %s\"
+3. gconftool-2 -s /desktop/gnome/url-handlers/lastfm/needs_terminal false -t bool
+4. gconftool-2 -t bool -s /desktop/gnome/url-handlers/lastfm/enabled true
+
+If you experience awkward fonts or widgets, try running qtconfig."
+
+ qt4-r2_src_prepare
+ # Use a different extensions path
+ epatch "${FILESDIR}"/${PN}-extensions-path.patch
+ einfo "Applying Debian patchset"
+ sed -i "/^tray-icon-size.diff/d" "${WORKDIR}"/debian/patches/series
+ cd "${S}"
+ for i in $( < "${WORKDIR}"/debian/patches/series); do
+ epatch "${WORKDIR}"/debian/patches/$i
+ done
+ if ! use ipod ; then
+ sed -i '/src\/mediadevices\/ipod/d' LastFM.pro || die "sed failed"
+ fi
+ #fix plugin search path for multilib support
+ sed -i -e "s:/usr/lib/:/usr/$(get_libdir)/:g" \
+ "${S}"/src/libMoose/MooseCommon.cpp
+ if use dbus; then
+ mv "${WORKDIR}"/dbus "${S}"/src/dbus
+ sed -i -e "/include/s:../definitions.pro.in:definitions.pro.in:" \
+ -e "/TARGET/s:dbusextension:LastFmDbusExtension:" \
+ "${S}"/src/dbus/dbusextension.pro
+ fi
+
+ # only glib.h can be included directly in >glib-2.32
+ epatch "${FILESDIR}"/${P}-glib.h.patch
+ # Gcc 4.7 definitions. Bug #423221
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+}
+
+src_configure() {
+ if use dbus; then
+ pushd "${S}"/src/dbus
+ eqmake4 dbusextension.pro
+ popd >> /dev/null
+ fi
+ qt4-r2_src_configure
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "emake failed"
+ if use dbus; then
+ einfo "Building DBUS plugin"
+ emake -C "${S}"/src/dbus || die "failed to build dbus extension"
+ fi
+ cd i18n; lrelease *.ts
+}
+
+src_install() {
+ cd "${WORKDIR}"
+ # Docs
+ dodoc "${S}"/ChangeLog.txt "${S}"/README debian/README.source
+ doman debian/lastfm.1
+
+ # Copied from debian/rules
+ insinto /usr/share
+ doins -r debian/package-files/share/icons || die "failed to install icons"
+ insinto /usr/share/lastfm/icons
+ doins "${S}"/bin/data/icons/*.png \
+ || die "failed to install application icons"
+ insinto /usr/share/lastfm
+ doins "${S}"/bin/data/*.png || die "failed to install icons"
+ dodir /usr/$(get_libdir)/lastfm_services/
+ insinto /usr/$(get_libdir)/lastfm_services/
+ insopts -m0755
+ doins -r "${S}"/bin/lastfm_services/*.so || die "failed to install plugins"
+ if use dbus; then
+ insinto /usr/$(get_libdir)/lastfm_services/extensions/
+ insopts -m0755
+ doins "${S}"/bin/lastfm_services/extensions/*.so
+ fi
+ insinto /usr/$(get_libdir)
+ insopts -m0755
+ doins "${S}"/bin/libLastFmTools.so.1* || die "failed to install library"
+ doins "${S}"/bin/libMoose.so.1* || die "failed to install library"
+ #fix symlinks
+ cd "${D}"/usr/$(get_libdir)/
+ ln -sfn libLastFmTools.so.1.0.0 libLastFmTools.so.1
+ ln -sfn libLastFmTools.so.1.0.0 libLastFmTools.so.1.0
+ ln -sfn libMoose.so.1.0.0 libMoose.so.1
+ ln -sfn libMoose.so.1.0.0 libMoose.so.1.0
+ cd "${WORKDIR}"
+ newbin "${S}"/bin/last.fm lastfm
+ insinto /usr/share/lastfm/i18n
+ doins "${S}"/i18n/*.qm || die "failed to install translations"
+ fperms 755 /usr/bin/lastfm
+ rm -f "${D}"/usr/share/lastfm/icons/{*profile24,systray_mac}.png
+ # create desktop entry
+ doicon "${WORKDIR}"/debian/package-files/share/icons/hicolor/48x48/apps/lastfm.png
+ # Allow arguments when launching application. Bug #395277
+ make_desktop_entry lastfm "Last.fm Player" lastfm
+ sed -i -e "/^Exec/s:lastfm:& %U:" \
+ "${D}"/usr/share/applications/lastfm-${PN}.desktop || die
+
+ readme.gentoo_create_doc
+}
diff --git a/media-sound/lastfmplayer/metadata.xml b/media-sound/lastfmplayer/metadata.xml
new file mode 100644
index 000000000000..e1774e3d9ad7
--- /dev/null
+++ b/media-sound/lastfmplayer/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sound</herd>
+</pkgmetadata>