summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-20 14:50:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-20 15:19:14 +0200
commit650ca5c01435e26014023eea70a5e647d4d30c81 (patch)
tree2ab425de3348173a99ae83899876d2522b0a001e /media-sound/qjackctl
parentdev-tcltk/tcl-mccp: remove last-rited pkg (diff)
downloadgentoo-650ca5c01435e26014023eea70a5e647d4d30c81.tar.gz
gentoo-650ca5c01435e26014023eea70a5e647d4d30c81.tar.bz2
gentoo-650ca5c01435e26014023eea70a5e647d4d30c81.zip
media-sound/qjackctl: EAPI-7 bump, missing || die
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/qjackctl')
-rw-r--r--media-sound/qjackctl/qjackctl-0.6.2.ebuild24
-rw-r--r--media-sound/qjackctl/qjackctl-9999.ebuild29
2 files changed, 26 insertions, 27 deletions
diff --git a/media-sound/qjackctl/qjackctl-0.6.2.ebuild b/media-sound/qjackctl/qjackctl-0.6.2.ebuild
index f8c94e1fdd3a..c145f659e40b 100644
--- a/media-sound/qjackctl/qjackctl-0.6.2.ebuild
+++ b/media-sound/qjackctl/qjackctl-0.6.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic qmake-utils xdg-utils
@@ -12,9 +12,9 @@ SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-
IUSE="alsa dbus debug portaudio"
+BDEPEND="dev-qt/linguist-tools:5"
RDEPEND="
app-arch/gzip
dev-qt/qtcore:5
@@ -26,18 +26,18 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
dbus? ( dev-qt/qtdbus:5 )
portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
+DEPEND="${RDEPEND}"
src_configure() {
append-cxxflags -std=c++11
- econf \
- $(use_enable alsa alsa-seq) \
- $(use_enable dbus) \
- $(use_enable debug) \
- $(use_enable portaudio) \
+ local myeconfargs=(
+ $(use_enable alsa alsa-seq)
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable portaudio)
--enable-jack-version
-
+ )
+ econf "${myeconfargs[@]}"
eqmake5 ${PN}.pro -o ${PN}.mak
}
@@ -48,8 +48,8 @@ src_compile() {
src_install() {
default
- gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz"
- gunzip "${D}/usr/share/man/man1/qjackctl.1.gz"
+ gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
+ gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
}
pkg_postinst() {
diff --git a/media-sound/qjackctl/qjackctl-9999.ebuild b/media-sound/qjackctl/qjackctl-9999.ebuild
index 87c768da8ec4..3d91bddef6f4 100644
--- a/media-sound/qjackctl/qjackctl-9999.ebuild
+++ b/media-sound/qjackctl/qjackctl-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit flag-o-matic qmake-utils autotools git-r3 xdg-utils
@@ -12,9 +12,9 @@ EGIT_REPO_URI="https://git.code.sf.net/p/qjackctl/code"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-
IUSE="alsa dbus debug portaudio"
+BDEPEND="dev-qt/linguist-tools:5"
RDEPEND="
app-arch/gzip
dev-qt/qtcore:5
@@ -26,24 +26,23 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
dbus? ( dev-qt/qtdbus:5 )
portaudio? ( media-libs/portaudio )"
-DEPEND="${RDEPEND}
- dev-qt/linguist-tools:5"
+DEPEND="${RDEPEND}"
src_prepare() {
- eautoreconf
-
default
+ eautoreconf
}
src_configure() {
append-cxxflags -std=c++11
- econf \
- $(use_enable alsa alsa-seq) \
- $(use_enable dbus) \
- $(use_enable debug) \
- $(use_enable portaudio) \
+ local myeconfargs=(
+ $(use_enable alsa alsa-seq)
+ $(use_enable dbus)
+ $(use_enable debug)
+ $(use_enable portaudio)
--enable-jack-version
-
+ )
+ econf "${myeconfargs[@]}"
eqmake5 ${PN}.pro -o ${PN}.mak
}
@@ -54,8 +53,8 @@ src_compile() {
src_install() {
default
- gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz"
- gunzip "${D}/usr/share/man/man1/qjackctl.1.gz"
+ gunzip "${D}/usr/share/man/man1/qjackctl.fr.1.gz" || die
+ gunzip "${D}/usr/share/man/man1/qjackctl.1.gz" || die
}
pkg_postinst() {