summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-03-24 07:14:05 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-03-24 07:14:14 +0100
commitab2f8606d32755aa0b481520d28b519fb1dceafc (patch)
tree5b61a8c55c31fe4c4b721ea0058f640f20002532 /media-sound/qsynth
parentdev-java/gradle-bin: Stabilize 8.0.1 x86, #902871 (diff)
downloadgentoo-ab2f8606d32755aa0b481520d28b519fb1dceafc.tar.gz
gentoo-ab2f8606d32755aa0b481520d28b519fb1dceafc.tar.bz2
gentoo-ab2f8606d32755aa0b481520d28b519fb1dceafc.zip
media-sound/qsynth: bump to 0.9.10
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch2
-rw-r--r--media-sound/qsynth/qsynth-0.9.10.ebuild71
3 files changed, 72 insertions, 2 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 818ae8ab2ba1..4f7287a71c87 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1,2 +1,3 @@
+DIST qsynth-0.9.10.tar.gz 333389 BLAKE2B 87ca02e1f15a7b28f5af462d1ef52e9609fc0abc3d15d545493f448da61d85d8d264f5ab908816607de3291424b979348f330205fc6e727edb7287fd28e9067d SHA512 82e04ccfe3193d570e28c4e5da3e9ea8afbc2b1f2e43f54459449b31ee5448a6232a5fe13631eed80a5cf75f4176e5a419ec6467bf3d7d5e30d34083d4d8f7aa
DIST qsynth-0.9.8.tar.gz 333010 BLAKE2B 60433afaccc6a1378b9799316bd8d4a0cbe3592059788feacf8564e6ee659ea61904358378d3307a12e706c8aeb70a51546063fc7f766091ea784f7e01bb780a SHA512 f193dcbce0b92e25d5310c5f6d78a6360a8a6f089efceae55b7a425a823d418618ee2fd0debca6b9e4793e988b92f2dd8c2f32812f21224e8e566ab15d4d5e64
DIST qsynth-0.9.9.tar.gz 333110 BLAKE2B efc22bc509445e1948d7dd28de8e6c6281967964dcf54e688a8830280945b37c51c70e0a64596bff2a7a12ccfcbaa3fd65d9465b11dc7abe2cca060cce6e3997 SHA512 79a3085a884b3bd3251ad059b8ab67eb3329f2e6b25df5dfa6d210d7d313000b52ccdfd8b9f18aa49bdc9db2a5cd1738f05c529cb4673bd579b4ba987b1edff6
diff --git a/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch b/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
index 9ea401abc26e..0a0dcd59ee13 100644
--- a/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
+++ b/media-sound/qsynth/files/qsynth-0.9.1-cmake-no-git-version.patch
@@ -1,5 +1,3 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 47ea36f..0194f32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,7 @@ project(qsynth
diff --git a/media-sound/qsynth/qsynth-0.9.10.ebuild b/media-sound/qsynth/qsynth-0.9.10.ebuild
new file mode 100644
index 000000000000..f7183956614e
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.10.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="amd64 ~ppc ppc64 x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}