summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-31 05:03:46 +0100
committerSam James <sam@gentoo.org>2022-05-31 05:07:00 +0100
commit5faee21836cdcd724ca89df47ae28620d5a56ad9 (patch)
tree69062451e1015f4e6d971d102a8c7adfc34ebec5 /media-sound/soundconverter
parentmedia-sound/soundconverter: add 4.0.3 (diff)
downloadgentoo-5faee21836cdcd724ca89df47ae28620d5a56ad9.tar.gz
gentoo-5faee21836cdcd724ca89df47ae28620d5a56ad9.tar.bz2
gentoo-5faee21836cdcd724ca89df47ae28620d5a56ad9.zip
media-sound/soundconverter: add partial test infrastructure; minor QA touchups
Closes: https://bugs.gentoo.org/758197 Bug: https://bugs.gentoo.org/846092 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound/soundconverter')
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.3.ebuild47
1 files changed, 41 insertions, 6 deletions
diff --git a/media-sound/soundconverter/soundconverter-4.0.3.ebuild b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
index 9840037dc60f..334ca9cba906 100644
--- a/media-sound/soundconverter/soundconverter-4.0.3.ebuild
+++ b/media-sound/soundconverter/soundconverter-4.0.3.ebuild
@@ -7,7 +7,7 @@ DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..10} )
PYTHON_REQ_USE="xml(+)"
-inherit distutils-r1 xdg
+inherit gnome2-utils distutils-r1 virtualx xdg
MY_PV="${PV/_/-}"
DESCRIPTION="A simple audiofile converter application for the GNOME environment"
@@ -16,8 +16,7 @@ SRC_URI="https://github.com/kassoulet/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="amd64 x86"
-
+KEYWORDS="~amd64 ~x86"
IUSE="aac flac mp3 ogg opus vorbis"
# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
@@ -47,18 +46,54 @@ BDEPEND="
$(python_gen_cond_dep '
dev-python/python-distutils-extra[${PYTHON_USEDEP}]
')
+ test? (
+ media-plugins/gst-plugins-flac:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ media-plugins/gst-plugins-faac:1.0
+ media-plugins/gst-plugins-opus:1.0
+ )
"
+# Before PEP517: tests seem to hang and also fail to find fdkaacenc from gst?
+# After: need to trick it into finding the data (inc. glade files)
+RESTRICT="test"
+
python_prepare_all() {
+ gnome2_environment_reset
distutils-r1_python_prepare_all
- rm -v "${S}/CHANGELOG.old"
+
+ rm -v "${S}/CHANGELOG.old" || die
+
# workaround incorrect behavior when LINGUAS is set to an empty string
# https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
}
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}"/data || die
+
+ "${EPYTHON}" tests/test.py || die
+}
+
python_install_all() {
- rm -v "${D}/usr/share/glib-2.0/schemas/gschemas.compiled"
- mv -v "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${P}"
+ rm -v "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+ mv -v "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
distutils-r1_python_install_all
}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}