summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/sox/sox-14.4.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/sox/sox-14.4.2.ebuild')
-rw-r--r--media-sound/sox/sox-14.4.2.ebuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/media-sound/sox/sox-14.4.2.ebuild b/media-sound/sox/sox-14.4.2.ebuild
new file mode 100644
index 000000000000..7dc1a267eb8d
--- /dev/null
+++ b/media-sound/sox/sox-14.4.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools
+
+DESCRIPTION="The swiss army knife of sound processing programs"
+HOMEPAGE="http://sox.sourceforge.net"
+SRC_URI="mirror://sourceforge/sox/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="alsa amr ao debug encode flac id3tag ladspa mad ogg openmp oss opus png pulseaudio sndfile static-libs twolame wavpack"
+
+RDEPEND="
+ dev-libs/libltdl:0=
+ >=media-sound/gsm-1.0.12-r1
+ alsa? ( media-libs/alsa-lib )
+ amr? ( media-libs/opencore-amr )
+ ao? ( media-libs/libao )
+ encode? ( >=media-sound/lame-3.98.4 )
+ flac? ( >=media-libs/flac-1.1.3 )
+ id3tag? ( media-libs/libid3tag )
+ ladspa? ( media-libs/ladspa-sdk )
+ mad? ( media-libs/libmad )
+ ogg? ( media-libs/libvorbis media-libs/libogg )
+ opus? ( media-libs/opus media-libs/opusfile )
+ png? ( media-libs/libpng:0= sys-libs/zlib )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndfile? ( >=media-libs/libsndfile-1.0.11 )
+ twolame? ( media-sound/twolame )
+ wavpack? ( media-sound/wavpack )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ sed -i -e 's:CFLAGS="-g":CFLAGS="$CFLAGS -g":' configure.ac || die #386027
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with alsa) \
+ $(use_with amr amrnb) \
+ $(use_with amr amrwb) \
+ $(use_with ao) \
+ $(use_enable debug) \
+ $(use_with encode lame) \
+ $(use_with flac) \
+ $(use_with id3tag) \
+ $(use_with ladspa) \
+ $(use_with mad) \
+ $(use_enable openmp) \
+ $(use_with ogg oggvorbis) \
+ $(use_with oss) \
+ $(use_with opus) \
+ $(use_with png) \
+ $(use_with pulseaudio) \
+ $(use_with sndfile) \
+ $(use_enable static-libs static) \
+ $(use_with twolame) \
+ $(use_with wavpack) \
+ --with-distro="Gentoo"
+}
+
+src_install() {
+ default
+ # libltdl is used for loading plugins, keeping libtool files with empty
+ # dependency_libs what otherwise would be -exec rm -f {} +
+ find "${ED}" -name '*.la' -exec sed -i -e "/^dependency_libs/s:=.*:='':" {} +
+}