summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-18 15:55:16 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-18 15:55:36 +0100
commit05b94c4ff0321bd3808ea738c7e78599ac43c574 (patch)
tree8ccfeace5ca16e181fbc6ab860130d946e4001a9 /media-sound
parentdev-java/opencsv: Stable for amd64. Retroactively mark stable for the remaini... (diff)
downloadgentoo-05b94c4ff0321bd3808ea738c7e78599ac43c574.tar.gz
gentoo-05b94c4ff0321bd3808ea738c7e78599ac43c574.tar.bz2
gentoo-05b94c4ff0321bd3808ea738c7e78599ac43c574.zip
media-sound/karlyriceditor: bump to 2.1, fix build with ffmpeg 3, bug #575062
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/karlyriceditor/Manifest1
-rw-r--r--media-sound/karlyriceditor/files/karlyriceditor-2.1-ffmpeg3.patch54
-rw-r--r--media-sound/karlyriceditor/karlyriceditor-2.1.ebuild44
3 files changed, 99 insertions, 0 deletions
diff --git a/media-sound/karlyriceditor/Manifest b/media-sound/karlyriceditor/Manifest
index 0f7be280ee0b..14211cd8bdd6 100644
--- a/media-sound/karlyriceditor/Manifest
+++ b/media-sound/karlyriceditor/Manifest
@@ -1,2 +1,3 @@
DIST karlyriceditor-1.11.tar.gz 275744 SHA256 55c074111d5e22950d9ef270d5c38f52bc3da167081efe570f77b8f4e578b8dc SHA512 d86cc10c18bff321d2f22b4b810bcc52189602bfddbe8cbdd99120cf281dc673221ce75c9a8e07b8bab03f9a60c3634853177b3fa72e3f1213b96a3303568820 WHIRLPOOL 9495665856346ab54a0662a2a89bb7a10358f16d9844491ddcb9105cc266c1994b786b60bf56b5c206e2740aa77599653cb5c23ae88cdb026bd44adafa7a77a8
DIST karlyriceditor-1.4.tar.gz 236662 SHA256 b458eb21087cd0d92e8ea87b4ac094a2126cfbcf6471b0b1ea03173cec0ebfef SHA512 ac92e8f67be46880e71082ae1b2d099deb15ca1abca1fdf7eb8539d0346ca223ee50d9739f7879699fb190e7bc544c2a753402804df20c9b4c35eefae2d3bdbb WHIRLPOOL 9072da5010deb34fe9e09dee165f824b3aeace89a3fd0c1b464def17cf767a5ee84a77d7b2f8696f81364be5bc54003243faba3870198ba084b98e3bc2207984
+DIST karlyriceditor-2.1.tar.gz 276784 SHA256 1f9ec6717491fac6dda1883dfdbc53d32d6031092b1afa78aa2077a36c54fb97 SHA512 3b07abb9151c745f126c3a8215e94e0d0a00fbf3732c30de7bf47b7013174dfd2d087a4ec2c23bcecf28cd0ba3f5513dd9cb5729ffd486df0bb804a250c24af6 WHIRLPOOL b68389ec853244a00884f3f304c3931cf3c1b97ca80731a4ec5a282ef4065551d14f9e312e47e4196972cbf7357bd8680b8783b887075106cf014be82d0b1d93
diff --git a/media-sound/karlyriceditor/files/karlyriceditor-2.1-ffmpeg3.patch b/media-sound/karlyriceditor/files/karlyriceditor-2.1-ffmpeg3.patch
new file mode 100644
index 000000000000..ebb9d5623396
--- /dev/null
+++ b/media-sound/karlyriceditor/files/karlyriceditor-2.1-ffmpeg3.patch
@@ -0,0 +1,54 @@
+Index: karlyriceditor-2.1/src/ffmpegvideodecoder.cpp
+===================================================================
+--- karlyriceditor-2.1.orig/src/ffmpegvideodecoder.cpp
++++ karlyriceditor-2.1/src/ffmpegvideodecoder.cpp
+@@ -151,12 +151,12 @@ bool FFMpegVideoDecoder::openFile( const
+ }
+
+ // Determine required buffer size and allocate buffer
+- int numBytes = avpicture_get_size( PIX_FMT_RGB24, d->pCodecCtx->width, d->pCodecCtx->height );
++ int numBytes = avpicture_get_size( AV_PIX_FMT_RGB24, d->pCodecCtx->width, d->pCodecCtx->height );
+ d->m_buffer.resize( numBytes );
+
+ // Assign appropriate parts of buffer to image planes in pFrameRGB
+ avpicture_fill( (AVPicture *) d->pFrameRGB, (uint8_t*) d->m_buffer.data(),
+- PIX_FMT_RGB24, d->pCodecCtx->width, d->pCodecCtx->height );
++ AV_PIX_FMT_RGB24, d->pCodecCtx->width, d->pCodecCtx->height );
+
+ d->skipFrames = seekto;
+ return true;
+@@ -215,7 +215,7 @@ bool FFMpegVideoDecoderPriv::readFrame(
+ int w = pCodecCtx->width;
+ int h = pCodecCtx->height;
+
+- img_convert_ctx = sws_getCachedContext(img_convert_ctx,w, h, pCodecCtx->pix_fmt, w, h, PIX_FMT_RGB24, SWS_BICUBIC, NULL, NULL, NULL);
++ img_convert_ctx = sws_getCachedContext(img_convert_ctx,w, h, pCodecCtx->pix_fmt, w, h, AV_PIX_FMT_RGB24, SWS_BICUBIC, NULL, NULL, NULL);
+
+ if ( img_convert_ctx == NULL )
+ {
+Index: karlyriceditor-2.1/src/ffmpegvideoencoder.cpp
+===================================================================
+--- karlyriceditor-2.1.orig/src/ffmpegvideoencoder.cpp
++++ karlyriceditor-2.1/src/ffmpegvideoencoder.cpp
+@@ -333,7 +333,7 @@ av_log_set_level(AV_LOG_VERBOSE);
+ videoCodecCtx->time_base.num = m_videoformat->frame_rate_num;
+ videoCodecCtx->time_base.den = m_videoformat->frame_rate_den;
+ videoCodecCtx->gop_size = (m_videoformat->frame_rate_den / m_videoformat->frame_rate_num) / 2; // GOP size is framerate / 2
+- videoCodecCtx->pix_fmt = PIX_FMT_YUV420P;
++ videoCodecCtx->pix_fmt = AV_PIX_FMT_YUV420P;
+ videoCodecCtx->bit_rate = m_videobitrate;
+ videoCodecCtx->bit_rate_tolerance = m_videobitrate * av_q2d(videoCodecCtx->time_base);
+
+@@ -865,10 +865,10 @@ bool FFMpegVideoEncoderPriv::convertImag
+ videoConvertCtx = sws_getCachedContext( videoConvertCtx,
+ m_videoformat->width,
+ m_videoformat->height,
+- PIX_FMT_BGRA,
++ AV_PIX_FMT_BGRA,
+ m_videoformat->width,
+ m_videoformat->height,
+- PIX_FMT_YUV420P,
++ AV_PIX_FMT_YUV420P,
+ SWS_BICUBIC,
+ NULL,
+ NULL,
diff --git a/media-sound/karlyriceditor/karlyriceditor-2.1.ebuild b/media-sound/karlyriceditor/karlyriceditor-2.1.ebuild
new file mode 100644
index 000000000000..8b13bcbb75e4
--- /dev/null
+++ b/media-sound/karlyriceditor/karlyriceditor-2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils qmake-utils
+
+DESCRIPTION="Application to edit and synchronize lyrics with karaoke songs in various formats"
+HOMEPAGE="http://www.ulduzsoft.com/linux/karaoke-lyrics-editor/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libav"
+
+RDEPEND="
+ dev-libs/openssl:0
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ media-libs/libsdl[sound]
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.11-libav.patch"
+ "${FILESDIR}/${PN}-2.1-ffmpeg3.patch"
+)
+
+src_configure() {
+ eqmake4 "${PN}.pro"
+}
+
+src_install() {
+ dodoc Changelog
+ dobin bin/${PN}
+ doicon packages/${PN}.png
+ make_desktop_entry ${PN} 'Karaoke Lyrics Editor'
+}