summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-06-03 14:48:04 +1000
committerMatt Jolly <kangie@gentoo.org>2024-06-03 15:02:59 +1000
commit1cf2e193f9cc134876eb77153415d96b1b9bf6e9 (patch)
treeaf245e7e1cf8c06b9f9ba8e597cfc7961e573ede /media-sound
parentmedia-sound/beets: add missing RDEPEND (diff)
downloadgentoo-1cf2e193f9cc134876eb77153415d96b1b9bf6e9.tar.gz
gentoo-1cf2e193f9cc134876eb77153415d96b1b9bf6e9.tar.bz2
gentoo-1cf2e193f9cc134876eb77153415d96b1b9bf6e9.zip
media-sound/beets: add missing USE=doc dependencies
Closes: https://bugs.gentoo.org/932479 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/beets/beets-1.7.0_pre20240501.ebuild3
-rw-r--r--media-sound/beets/beets-9999.ebuild5
2 files changed, 5 insertions, 3 deletions
diff --git a/media-sound/beets/beets-1.7.0_pre20240501.ebuild b/media-sound/beets/beets-1.7.0_pre20240501.ebuild
index ea51e978cc1d..71c42d29cfe8 100644
--- a/media-sound/beets/beets-1.7.0_pre20240501.ebuild
+++ b/media-sound/beets/beets-1.7.0_pre20240501.ebuild
@@ -57,6 +57,7 @@ DEPEND="
BDEPEND="
doc? (
dev-python/sphinx
+ dev-python/pydata-sphinx-theme
)
$(python_gen_cond_dep '
test? (
@@ -124,7 +125,7 @@ python_prepare_all() {
python_compile_all() {
if use doc ; then
- sphinx-build -b html docs docs/build || die
+ sphinx-build -b html docs docs/build/html || die
fi
# If building from VCS sources we need to generate manpages, then copy them to ${S}/man
# We could install mans from the sphinx build path, but to be consistent with pypi for src_install
diff --git a/media-sound/beets/beets-9999.ebuild b/media-sound/beets/beets-9999.ebuild
index 5dbc70f0225d..00a1c997e652 100644
--- a/media-sound/beets/beets-9999.ebuild
+++ b/media-sound/beets/beets-9999.ebuild
@@ -55,6 +55,7 @@ DEPEND="
BDEPEND="
doc? (
dev-python/sphinx
+ dev-python/pydata-sphinx-theme
)
$(python_gen_cond_dep '
test? (
@@ -110,7 +111,7 @@ src_prepare() {
sed -i -e "/--cov=beets/,+9d" setup.cfg || die "Failed to disable code coverage options in setup.cfg"
# Update the version if we're not building from pypy; it's probably a _pre or live ebuild.
if [[ ${PV} == "9999" ]] || [[ ${UPDATE_VERSION} == "yes" ]]; then
- sed -i -e "s/version=\".*\"/version=\"${PV}\"/" setup.py || die "Failed to update version in VCS sources"
+ sed -i -e "s/version='.*'/version='${PV}'/" setup.py || die "Failed to update version in VCS sources"
sed -i -e "s/__version__ = \".*\"/__version__ = \"${PV}\"/" beets/__init__.py
fi
default
@@ -122,7 +123,7 @@ python_prepare_all() {
python_compile_all() {
if use doc ; then
- sphinx-build -b html docs docs/build || die
+ sphinx-build -b html docs docs/build/html || die
fi
# If building from VCS sources we need to generate manpages, then copy them to ${S}/man
# We could install mans from the sphinx build path, but to be consistent with pypi for src_install