summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-07-10 08:02:33 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-07-10 08:02:40 +0200
commit45666a000d74babba76279fd2ae998ac74596796 (patch)
tree80036db7fc3e43c3fb0bb94baa975f43ee81ad31 /media-sound
parentmail-client/mutt-wizard: mark ALLARCHES (diff)
downloadgentoo-45666a000d74babba76279fd2ae998ac74596796.tar.gz
gentoo-45666a000d74babba76279fd2ae998ac74596796.tar.bz2
gentoo-45666a000d74babba76279fd2ae998ac74596796.zip
media-sound/cmusfm: bump to 0.5.0
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cmusfm/Manifest1
-rw-r--r--media-sound/cmusfm/cmusfm-0.5.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/media-sound/cmusfm/Manifest b/media-sound/cmusfm/Manifest
index 032bfcdc977f..83cf3ddda253 100644
--- a/media-sound/cmusfm/Manifest
+++ b/media-sound/cmusfm/Manifest
@@ -1 +1,2 @@
DIST cmusfm-0.4.1.tar.gz 41960 BLAKE2B 4de96b821c56f64c485dae8ff1e4d342e8f1548650a455ec707f01f53afeb7ca3e333ca62b514e2389a884d9138eb5d228a7376c5a1d5cdd163abc8ab9482608 SHA512 994599675822de5f809b3eedc423c37afe24e88df29fe4474d1834bf1e9573464d2bdbb084181db1d6c3bc0541891ccbb4514afa066c034e39035192ebc95211
+DIST cmusfm-0.5.0.tar.gz 43491 BLAKE2B 591aab46e98419fb767069786a3423c6190f2adc51884dc85e36560d9a01fc87d9f244953bcdec59ddad48d2e2c449a8afa0a8f1cc63cce686ae2154824aafdf SHA512 497ba0c9f776b8d2f11934a5dbc2ea4b4971511f3c3c4df602d1742ba5fcaf4c0f91d5f8a1ebe849e184718e7090fcf146560445398e85f97722bb62c0976fd3
diff --git a/media-sound/cmusfm/cmusfm-0.5.0.ebuild b/media-sound/cmusfm/cmusfm-0.5.0.ebuild
new file mode 100644
index 000000000000..e891db66beda
--- /dev/null
+++ b/media-sound/cmusfm/cmusfm-0.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools readme.gentoo-r1
+
+DESCRIPTION="Last.fm scrobbler for cmus music player"
+HOMEPAGE="https://github.com/Arkq/cmusfm"
+SRC_URI="https://github.com/Arkq/cmusfm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="libnotify"
+
+DEPEND="
+ net-misc/curl
+ dev-libs/openssl:0=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ media-sound/cmus
+"
+BDEPEND="virtual/pkgconfig"
+
+DOC_CONTENTS="Please refer to the README.md file before running cmusfm the first time."
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable libnotify)
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}