summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-27 04:57:09 +0000
committerSam James <sam@gentoo.org>2024-11-27 04:57:09 +0000
commitb8e4dcb390354d12e7a2b2a3647bea9ef7e097b9 (patch)
treeefbd890aad5d29d66437bea430ceab065c3a7398 /media-sound
parentnet-nntp/slrn: add missing include (diff)
downloadgentoo-b8e4dcb390354d12e7a2b2a3647bea9ef7e097b9.tar.gz
gentoo-b8e4dcb390354d12e7a2b2a3647bea9ef7e097b9.tar.bz2
gentoo-b8e4dcb390354d12e7a2b2a3647bea9ef7e097b9.zip
media-sound/vorbisgain: fix modern C issue in configure
Closes: https://bugs.gentoo.org/899862 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/vorbisgain/vorbisgain-0.37-r5.ebuild (renamed from media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild)14
1 files changed, 12 insertions, 2 deletions
diff --git a/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild b/media-sound/vorbisgain/vorbisgain-0.37-r5.ebuild
index 885e785ad58c..c16c25117304 100644
--- a/media-sound/vorbisgain/vorbisgain-0.37-r4.ebuild
+++ b/media-sound/vorbisgain/vorbisgain-0.37-r5.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit autotools
+
DESCRIPTION="Calculator of perceived sound level for Ogg Vorbis files"
HOMEPAGE="https://sjeng.org/vorbisgain.html"
SRC_URI="https://sjeng.org/ftp/vorbis/${P}.tar.gz"
@@ -13,7 +15,8 @@ KEYWORDS="amd64 ppc ppc64 ~riscv sparc x86"
RDEPEND="
media-libs/libogg
- media-libs/libvorbis"
+ media-libs/libvorbis
+"
DEPEND="${RDEPEND}"
PATCHES=(
@@ -23,6 +26,13 @@ PATCHES=(
"${FILESDIR}"/${P}-wformat-security.patch
)
+src_prepare() {
+ default
+
+ # bug #899862
+ eautoreconf
+}
+
src_configure() {
econf --enable-recursive
}