summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-20 19:21:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-20 20:11:56 +0200
commit8478b2adcc1c58c77e882f6230832a7c2555a500 (patch)
treee695d789df339c0c34b757c89636d37683ccb867 /media-video/dvdstyler
parentmedia-libs/aubio: fix build with ffmpeg4 (diff)
downloadgentoo-8478b2adcc1c58c77e882f6230832a7c2555a500.tar.gz
gentoo-8478b2adcc1c58c77e882f6230832a7c2555a500.tar.bz2
gentoo-8478b2adcc1c58c77e882f6230832a7c2555a500.zip
media-video/dvdstyler: fix build with ffmpeg4
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'media-video/dvdstyler')
-rw-r--r--media-video/dvdstyler/dvdstyler-3.0.4.ebuild2
-rw-r--r--media-video/dvdstyler/files/ffmpeg4.patch13
2 files changed, 15 insertions, 0 deletions
diff --git a/media-video/dvdstyler/dvdstyler-3.0.4.ebuild b/media-video/dvdstyler/dvdstyler-3.0.4.ebuild
index 668ddd64d8d3..3df313a5bb0d 100644
--- a/media-video/dvdstyler/dvdstyler-3.0.4.ebuild
+++ b/media-video/dvdstyler/dvdstyler-3.0.4.ebuild
@@ -46,6 +46,8 @@ DEPEND="${COMMON_DEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}/ffmpeg4.patch"
+
need-wxwidgets unicode
# disable obsolete GNOME 2.x libraries wrt #508854
sed -i -e '/PKG_CONFIG/s:libgnomeui-2.0:dIsAbLeAuToMaGiC&:' configure || die
diff --git a/media-video/dvdstyler/files/ffmpeg4.patch b/media-video/dvdstyler/files/ffmpeg4.patch
new file mode 100644
index 000000000000..39966dd1dfb8
--- /dev/null
+++ b/media-video/dvdstyler/files/ffmpeg4.patch
@@ -0,0 +1,13 @@
+Index: DVDStyler-3.0.4/src/mediaenc_ffmpeg.cpp
+===================================================================
+--- DVDStyler-3.0.4.orig/src/mediaenc_ffmpeg.cpp
++++ DVDStyler-3.0.4/src/mediaenc_ffmpeg.cpp
+@@ -223,7 +223,7 @@ bool wxFfmpegMediaEncoder::addAudioStrea
+ c->time_base = (AVRational){ 1, c->sample_rate };
+ // some formats want stream headers to be separate
+ if(m_outputCtx->oformat->flags & AVFMT_GLOBALHEADER)
+- c->flags |= CODEC_FLAG_GLOBAL_HEADER;
++ c->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
+
+ return true;
+ }