summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2024-06-16 19:28:09 +0200
committerLouis Sautier <sbraz@gentoo.org>2024-06-16 19:31:09 +0200
commit0820c8c16d45081680ea1ca72fc2db79aab0639c (patch)
tree723017093d5460f6dd56779da316fdbd8c024e95 /media-video/gaupol/gaupol-1.15.ebuild
parentsys-kernel/gentoo-sources: add 6.9.5 (diff)
downloadgentoo-0820c8c16d45081680ea1ca72fc2db79aab0639c.tar.gz
gentoo-0820c8c16d45081680ea1ca72fc2db79aab0639c.tar.bz2
gentoo-0820c8c16d45081680ea1ca72fc2db79aab0639c.zip
media-video/gaupol: add 1.15, enable Python 3.13
In this release, chardet was replaced with charset-normalizer. Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'media-video/gaupol/gaupol-1.15.ebuild')
-rw-r--r--media-video/gaupol/gaupol-1.15.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-video/gaupol/gaupol-1.15.ebuild b/media-video/gaupol/gaupol-1.15.ebuild
new file mode 100644
index 000000000000..de6253f7c5e9
--- /dev/null
+++ b/media-video/gaupol/gaupol-1.15.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 virtualx xdg-utils
+
+DESCRIPTION="A subtitle editor for text-based subtitles"
+HOMEPAGE="https://otsaloma.io/gaupol/ https://github.com/otsaloma/gaupol/"
+SRC_URI="https://github.com/otsaloma/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="spell"
+
+RDEPEND="
+ app-text/iso-codes
+ dev-python/charset-normalizer[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ spell? ( app-text/gspell[introspection] )
+"
+BDEPEND="
+ sys-devel/gettext
+ test? (
+ app-dicts/myspell-en
+ app-text/enchant[hunspell]
+ app-text/gspell[introspection]
+ )
+"
+
+distutils_enable_tests pytest
+
+DOCS=( AUTHORS.md NEWS.md README.md README.aeidon.md )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12-fix-prefix.patch"
+)
+
+python_test() {
+ virtx epytest
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "The integrated video player requires media-plugins/gst-plugins-gtk."
+ elog ""
+ elog "External video previewing support requires MPV, MPlayer or VLC."
+ if use spell; then
+ elog ""
+ elog "Spell-checking requires a dictionary, any of app-dicts/myspell-*"
+ elog "or app-text/aspell with the appropriate L10N variable."
+ elog ""
+ elog "Additionally, make sure that app-text/enchant has the correct flags enabled:"
+ elog "USE=hunspell for myspell dictionaries and USE=aspell for aspell dictionaries."
+ fi
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}