summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/pymp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/pymp')
-rw-r--r--media-video/pymp/Manifest1
-rw-r--r--media-video/pymp/metadata.xml8
-rw-r--r--media-video/pymp/pymp-1.1.ebuild48
3 files changed, 57 insertions, 0 deletions
diff --git a/media-video/pymp/Manifest b/media-video/pymp/Manifest
new file mode 100644
index 000000000000..2d746ba5703e
--- /dev/null
+++ b/media-video/pymp/Manifest
@@ -0,0 +1 @@
+DIST pymp-1.1.tar.bz2 132710 SHA256 924c7d0a40d349f4dfc9a0bae2126a432185dc210f740dfc6ab68fd3ec892cd8 SHA512 10647af1233c5a030cc32f5efb7790fb93568832547f8c886d49597cff36f5d5606b7b06c00c0206e9eacd6331dbb40bc2331dc30230052b4510be1ffec34500 WHIRLPOOL 1a99e46f94cc1af7bddae4cfc182f4d94530664e324322663534f187a28beb3c7610d9c4bd790142e5ad59d7ec5ddd9e22d153e60aa8181b91be64216334528f
diff --git a/media-video/pymp/metadata.xml b/media-video/pymp/metadata.xml
new file mode 100644
index 000000000000..0d9b0dcb7f33
--- /dev/null
+++ b/media-video/pymp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/media-video/pymp/pymp-1.1.ebuild b/media-video/pymp/pymp-1.1.ebuild
new file mode 100644
index 000000000000..45f0b0c24b46
--- /dev/null
+++ b/media-video/pymp/pymp-1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+PYTHON_DEPEND="2:2.5"
+inherit eutils multilib python
+
+DESCRIPTION="a lean, flexible frontend to mplayer written in python"
+HOMEPAGE="http://jdolan.dyndns.org/trac/wiki/Pymp"
+SRC_URI="http://jdolan.dyndns.org/jaydolan/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-fbsd"
+IUSE=""
+
+RDEPEND="media-video/mplayer
+ dev-python/pygtk"
+DEPEND="sys-apps/sed"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e "s/python/python2/" -e "s:PREFIX/lib:/usr/$(get_libdir):" pymp || die "sed failed"
+}
+
+src_compile() { :; }
+
+src_install() {
+ dobin pymp || die "dobin failed"
+ insinto /usr/$(get_libdir)/pymp
+ doins *.py || die "doins failed"
+ dodoc CHANGELOG README
+ doicon pymp.png
+ make_desktop_entry pymp Pymp pymp
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/pymp
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/pymp
+}