summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2016-09-03 23:18:53 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-14 13:15:42 +0200
commit3252a86b2afff788707c84c540504cca87ac8630 (patch)
tree67a3b02d1a36b2e476547aece02efa5477567c95 /media-video/rtmpdump
parentmedia-video/rtmpdump: Shrink DESCRIPTION. (diff)
downloadgentoo-3252a86b2afff788707c84c540504cca87ac8630.tar.gz
gentoo-3252a86b2afff788707c84c540504cca87ac8630.tar.bz2
gentoo-3252a86b2afff788707c84c540504cca87ac8630.zip
media-video/rtmpdump: Move to EAPI6 and git-r3.
Specify dev-libs/openssl and dev-libs/libressl SLOT. Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/2210 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'media-video/rtmpdump')
-rw-r--r--media-video/rtmpdump/rtmpdump-2.4_p20131018-r1.ebuild79
-rw-r--r--media-video/rtmpdump/rtmpdump-9999.ebuild13
2 files changed, 87 insertions, 5 deletions
diff --git a/media-video/rtmpdump/rtmpdump-2.4_p20131018-r1.ebuild b/media-video/rtmpdump/rtmpdump-2.4_p20131018-r1.ebuild
new file mode 100644
index 000000000000..5a9d6d343eb7
--- /dev/null
+++ b/media-video/rtmpdump/rtmpdump-2.4_p20131018-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit multilib toolchain-funcs multilib-minimal
+
+DESCRIPTION="RTMP client intended to stream audio or video flash content"
+HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
+SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+# the library is LGPL-2.1, the command is GPL-2
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~amd64-fbsd ~amd64-linux ~arm ~hppa ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-linux"
+IUSE="gnutls polarssl ssl libressl"
+
+DEPEND="ssl? (
+ gnutls? ( >=net-libs/gnutls-2.12.23-r6[${MULTILIB_USEDEP},nettle(+)] )
+ polarssl? ( !gnutls? ( >=net-libs/polarssl-1.3.4[${MULTILIB_USEDEP}] ) )
+ !gnutls? ( !polarssl? ( !libressl? ( >=dev-libs/openssl-1.0.1h-r2:0[${MULTILIB_USEDEP}] ) libressl? ( dev-libs/libressl:0 ) ) )
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ )"
+RDEPEND="${DEPEND}"
+
+DOCS=( README ChangeLog )
+HTML_DOCS=( rtmpdump.1.html rtmpgw.8.html )
+
+pkg_setup() {
+ if ! use ssl && { use gnutls || use polarssl; }; then
+ ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
+ ewarn "Please review the local USE flags for this package."
+ fi
+}
+
+src_prepare() {
+ default
+
+ # fix #571106 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ # fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
+ sed -i 's/\$(MAKEFLAGS)//g' Makefile \
+ || die "failed to fix Makefile"
+ sed -i -e 's:OPT=:&-fPIC :' \
+ -e 's:OPT:OPTS:' \
+ -e 's:CFLAGS=.*:& $(OPT):' librtmp/Makefile \
+ || die "failed to fix Makefile"
+ multilib_copy_sources
+
+ if use ssl ; then
+ if use gnutls ; then
+ crypto="GNUTLS"
+ elif use polarssl ; then
+ crypto="POLARSSL"
+ else
+ crypto="OPENSSL"
+ fi
+ fi
+}
+
+multilib_src_compile() {
+ #fix multilib-script support. Bug #327449
+ sed -i "/^libdir/s:lib$:$(get_libdir):" librtmp/Makefile || die
+ if ! multilib_is_native_abi; then
+ cd librtmp || die
+ fi
+ emake CC="$(tc-getCC)" LD="$(tc-getLD)" \
+ OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix
+}
+
+multilib_src_install() {
+ mkdir -p "${ED}"/usr/$(get_libdir) || die
+ if ! multilib_is_native_abi; then
+ cd librtmp || die
+ fi
+ emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \
+ CRYPTO="${crypto}" install
+}
diff --git a/media-video/rtmpdump/rtmpdump-9999.ebuild b/media-video/rtmpdump/rtmpdump-9999.ebuild
index c9348c0dbd97..4c568c33bd0a 100644
--- a/media-video/rtmpdump/rtmpdump-9999.ebuild
+++ b/media-video/rtmpdump/rtmpdump-9999.ebuild
@@ -2,9 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI="4"
+EAPI="6"
-inherit git-2 multilib toolchain-funcs multilib-minimal
+inherit git-r3 multilib toolchain-funcs multilib-minimal
DESCRIPTION="RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
@@ -24,6 +24,9 @@ DEPEND="ssl? (
)"
RDEPEND="${DEPEND}"
+DOCS=( README ChangeLog )
+HTML_DOCS=( rtmpdump.1.html rtmpgw.8.html )
+
pkg_setup() {
if ! use ssl && { use gnutls || use polarssl; }; then
ewarn "USE='gnutls polarssl' are ignored without USE='ssl'."
@@ -32,6 +35,8 @@ pkg_setup() {
}
src_prepare() {
+ default
+
# fix #571106 by restoring pre-GCC5 inline semantics
append-cflags -std=gnu89
# fix Makefile ( bug #298535 , bug #318353 and bug #324513 )
@@ -65,9 +70,7 @@ multilib_src_compile() {
multilib_src_install() {
mkdir -p "${ED}"/usr/$(get_libdir) || die
- if multilib_is_native_abi; then
- dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html
- else
+ if ! multilib_is_native_abi; then
cd librtmp || die
fi
emake DESTDIR="${ED}" prefix="/usr" mandir="/usr/share/man" \