summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/subdl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/subdl')
-rw-r--r--media-video/subdl/Manifest1
-rw-r--r--media-video/subdl/metadata.xml11
-rw-r--r--media-video/subdl/subdl-1.0.3.ebuild33
3 files changed, 45 insertions, 0 deletions
diff --git a/media-video/subdl/Manifest b/media-video/subdl/Manifest
new file mode 100644
index 000000000000..ad02fb5a257e
--- /dev/null
+++ b/media-video/subdl/Manifest
@@ -0,0 +1 @@
+DIST subdl-1.0.3.zip 17212 SHA256 ba56d0f65ccce575295a65d1374f164d4f1cc69c874ae8593f5daa688562c154 SHA512 d3c0e036bece8c6cad7b37543f8e2f00906ce83738aa3d751e463d316ee97292d696c0eae01d71f28fd67b942b9d28c00c8e580036d19933dbd4143e9865078c WHIRLPOOL 84418baa515a707b7e41d1823708ddfdad7e66d6f431872862de4c4de7c44d2cff18f1d75a3ae45977fa49271c7184fe8fe225d5e6b44c3d64bde25a58033603
diff --git a/media-video/subdl/metadata.xml b/media-video/subdl/metadata.xml
new file mode 100644
index 000000000000..564e8cdd2612
--- /dev/null
+++ b/media-video/subdl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="google-code">subdl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-video/subdl/subdl-1.0.3.ebuild b/media-video/subdl/subdl-1.0.3.ebuild
new file mode 100644
index 000000000000..9781470c4277
--- /dev/null
+++ b/media-video/subdl/subdl-1.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit python-single-r1
+
+DESCRIPTION="A command-line tool for downloading subs from opensubtitles.org"
+HOMEPAGE="http://code.google.com/p/subdl/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+S=${WORKDIR}
+
+src_prepare() {
+ python_fix_shebang ${PN}
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README.txt
+}