summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFelix Neumärker <xdch47@posteo.de>2023-10-24 21:18:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-01-10 11:06:08 +0200
commita81e35bc0b3f0dc40fa697bb6b21e896ba808f67 (patch)
treea01c13ee377d8bb8b4208775cf826b3f4bc6acf9 /media-video
parentx11-themes/numix-icon-theme-circle: add 23.10.09 (diff)
downloadgentoo-a81e35bc0b3f0dc40fa697bb6b21e896ba808f67.tar.gz
gentoo-a81e35bc0b3f0dc40fa697bb6b21e896ba808f67.tar.bz2
gentoo-a81e35bc0b3f0dc40fa697bb6b21e896ba808f67.zip
media-video/shotcut: bump to 23.09.29 (qt6), drop 22.09.23
Thanks to Lorenzo Bertini. Closes: https://bugs.gentoo.org/831333 Closes: https://bugs.gentoo.org/908846 Signed-off-by: Felix Neumärker <xdch47@posteo.de> Closes: https://github.com/gentoo/gentoo/pull/33498 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'media-video')
-rw-r--r--media-video/shotcut/Manifest2
-rw-r--r--media-video/shotcut/shotcut-23.09.29.ebuild (renamed from media-video/shotcut/shotcut-22.09.23.ebuild)35
-rw-r--r--media-video/shotcut/shotcut-9999.ebuild35
3 files changed, 33 insertions, 39 deletions
diff --git a/media-video/shotcut/Manifest b/media-video/shotcut/Manifest
index 2a60ada06532..922450a8419c 100644
--- a/media-video/shotcut/Manifest
+++ b/media-video/shotcut/Manifest
@@ -1,2 +1,2 @@
-DIST shotcut-22.09.23.tar.gz 9096319 BLAKE2B 4023ca82f72e5fb3dca9dfed18912f0b8a99ef5915b0bb1ca983269b99b4b057747558801e2dfe65c89e68c4e9fcfc0a1cc9bcc24ce4d44d1e5453b94d639da2 SHA512 3c680a36ed4e22e857a824eaa25a63aa6cb830751e9730d4cd5e0a6fa2b087d9b63900232155fe5f656a4d70ae27dabc5fad52ed39d6b53f99188c954f9896d8
DIST shotcut-22.12.21.tar.gz 9857227 BLAKE2B 94739b1f2d66c8d4ebc69ded7c90a75f973b17889fce538855403f92b5232514df45f6e3648ef772b9a22c27b547ce2b7f0f6eb391cc47dfebaf9907f0c6525f SHA512 95ca399657934becedd71c3daa74749bca1b625a0cedf8df4bfd212476602f83f5b807b26ec7c8275ee720e54893102931bf109c95153fc16f348d344e50395b
+DIST shotcut-23.09.29.tar.gz 11908874 BLAKE2B e107d5f0284afd54b31eff72220d4224621da7b46fff6345d729ea0464b8967bc3329a12121aeedcdec6bcce7f4c6394065463269708a4bd4d29cc4389bc1706 SHA512 a829c2eda51db4fe20fa207e3e98ce0fb1e777af8ac495aa1ad20407bb91a41fed569298611288e04a528f1120fc89292d0333d3e445dce1ab86a799dea78e16
diff --git a/media-video/shotcut/shotcut-22.09.23.ebuild b/media-video/shotcut/shotcut-23.09.29.ebuild
index 937c3ecd7cc2..ca61874e186c 100644
--- a/media-video/shotcut/shotcut-22.09.23.ebuild
+++ b/media-video/shotcut/shotcut-23.09.29.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ DESCRIPTION="A free, open source, cross-platform video editor"
HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
if [[ ${PV} != 9999* ]] ; then
SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
else
inherit git-r3
EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
@@ -21,34 +21,31 @@ LICENSE="GPL-3+"
SLOT="0"
BDEPEND="
- dev-qt/linguist-tools:5
+ dev-qt/qttools:6[linguist]
"
COMMON_DEPEND="
- dev-qt/qtdeclarative:5[widgets]
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtsql:5
- dev-qt/qtwebsockets:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- >=media-libs/mlt-7.8.0[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
+ dev-qt/qtbase:6[concurrent,gui,network,opengl,sql,widgets,xml]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtmultimedia:6
+ >=media-libs/mlt-7.18.0[ffmpeg,frei0r,jack,opengl,sdl,xml]
media-video/ffmpeg
"
-DEPEND="${COMMON_DEPEND}
- dev-qt/qtconcurrent:5
- dev-qt/qtx11extras:5
-"
+
+DEPEND="${COMMON_DEPEND}"
+
RDEPEND="${COMMON_DEPEND}
- dev-qt/qtgraphicaleffects:5
virtual/jack
"
src_configure() {
CMAKE_BUILD_TYPE=$(usex debug Debug Release)
+ if [[ ${PV} != 9999* ]] ; then
+ SHOTCUT_VERSION="${PV}"
+ else
+ SHOTCUT_VERSION="$(git log --date=format:'%y.%m.%d' -1 --format='%ad')"
+ fi
local mycmakeargs=(
- -DSHOTCUT_VERSION="${PV}"
+ -DSHOTCUT_VERSION="${SHOTCUT_VERSION}"
)
use debug || append-cxxflags "-DNDEBUG"
append-cxxflags "-DSHOTCUT_NOUPGRADE"
diff --git a/media-video/shotcut/shotcut-9999.ebuild b/media-video/shotcut/shotcut-9999.ebuild
index 937c3ecd7cc2..ca61874e186c 100644
--- a/media-video/shotcut/shotcut-9999.ebuild
+++ b/media-video/shotcut/shotcut-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ DESCRIPTION="A free, open source, cross-platform video editor"
HOMEPAGE="https://www.shotcut.org/ https://github.com/mltframework/shotcut/"
if [[ ${PV} != 9999* ]] ; then
SRC_URI="https://github.com/mltframework/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64"
else
inherit git-r3
EGIT_REPO_URI="https://github.com/mltframework/shotcut/"
@@ -21,34 +21,31 @@ LICENSE="GPL-3+"
SLOT="0"
BDEPEND="
- dev-qt/linguist-tools:5
+ dev-qt/qttools:6[linguist]
"
COMMON_DEPEND="
- dev-qt/qtdeclarative:5[widgets]
- dev-qt/qtmultimedia:5
- dev-qt/qtnetwork:5
- dev-qt/qtopengl:5
- dev-qt/qtquickcontrols2:5
- dev-qt/qtsql:5
- dev-qt/qtwebsockets:5
- dev-qt/qtwidgets:5
- dev-qt/qtxml:5
- >=media-libs/mlt-7.8.0[ffmpeg,frei0r,fftw(+),jack,opengl,qt5,sdl,xml]
+ dev-qt/qtbase:6[concurrent,gui,network,opengl,sql,widgets,xml]
+ dev-qt/qtdeclarative:6[widgets]
+ dev-qt/qtmultimedia:6
+ >=media-libs/mlt-7.18.0[ffmpeg,frei0r,jack,opengl,sdl,xml]
media-video/ffmpeg
"
-DEPEND="${COMMON_DEPEND}
- dev-qt/qtconcurrent:5
- dev-qt/qtx11extras:5
-"
+
+DEPEND="${COMMON_DEPEND}"
+
RDEPEND="${COMMON_DEPEND}
- dev-qt/qtgraphicaleffects:5
virtual/jack
"
src_configure() {
CMAKE_BUILD_TYPE=$(usex debug Debug Release)
+ if [[ ${PV} != 9999* ]] ; then
+ SHOTCUT_VERSION="${PV}"
+ else
+ SHOTCUT_VERSION="$(git log --date=format:'%y.%m.%d' -1 --format='%ad')"
+ fi
local mycmakeargs=(
- -DSHOTCUT_VERSION="${PV}"
+ -DSHOTCUT_VERSION="${SHOTCUT_VERSION}"
)
use debug || append-cxxflags "-DNDEBUG"
append-cxxflags "-DSHOTCUT_NOUPGRADE"