summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-17 02:58:21 +0000
committerSam James <sam@gentoo.org>2021-05-17 02:58:21 +0000
commit574408eb9ce5a47032222ee474e754b46f4a1c87 (patch)
treea4666ea029325b915dd2899b94c60d0c94c7cbf6 /net-analyzer/cacti-spine
parentnet-analyzer/cacti: add 1.2.17 (diff)
downloadgentoo-574408eb9ce5a47032222ee474e754b46f4a1c87.tar.gz
gentoo-574408eb9ce5a47032222ee474e754b46f4a1c87.tar.bz2
gentoo-574408eb9ce5a47032222ee474e754b46f4a1c87.zip
net-analyzer/cacti-spine: add 1.2.17
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti-spine')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index 0da9f590a8d7..9d350c261ff8 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-1.2.16.tar.gz 108252 BLAKE2B ba0349cff7f4e82a5dc1d90c216cf7a4e0f939e28ab20d008b1725c948a85a00e2594f8997c8bbd69c305e3e58d944858c8439210956f45220b67229bc6df13d SHA512 0259084d70f9c8d20a8b19daf61e525228f99fba3eac4e2e5c9865114a5f1231b18389ca955fc4644c71c6c48cc45dda9b17e969a02c80552b84f98ad8945951
+DIST cacti-spine-1.2.17.tar.gz 110371 BLAKE2B 1f9605d34fcff0e4e7921ccbb5a22eeb9e2f2e2f22cf56189790dcdec798db5bff681df11cd82006254cc270174248c07ce3d94dca8d3367add6b220f1599adf SHA512 4c616af041d2f08e18fd274409c98d3efce84b7cca2d6e23db3d6c2a0d4c9a77a2c52c0ef8e0ed0c6ad409f28b56fdf3160e27654522d8aeb1b88e3cb4128d4a
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild
new file mode 100644
index 000000000000..32cee3944471
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.2.17.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="https://cacti.net/spine_info.php"
+SRC_URI="https://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="sys-apps/help2man"
+DEPEND="
+ dev-libs/openssl:0=
+ net-analyzer/net-snmp:=
+ dev-db/mysql-connector-c:0=
+"
+RDEPEND="
+ ${DEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dosbin spine
+
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+
+ doman spine.1
+ dodoc CHANGELOG
+}