summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-04-06 07:58:45 +0200
committerJeroen Roovers <jer@gentoo.org>2020-04-06 08:00:52 +0200
commit1e32b6db4a86b16720629c6ac634e0b2c8214753 (patch)
tree776108901649ff117b670f8963cb5601a89aef81 /net-analyzer/cacti
parentxfce-extra/thunar-shares-plugin: Bump to 0.3.1 (diff)
downloadgentoo-1e32b6db4a86b16720629c6ac634e0b2c8214753.tar.gz
gentoo-1e32b6db4a86b16720629c6ac634e0b2c8214753.tar.bz2
gentoo-1e32b6db4a86b16720629c6ac634e0b2c8214753.zip
net-analyzer/cacti: Version 1.2.11
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/Manifest1
-rw-r--r--net-analyzer/cacti/cacti-1.2.11.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 157d37ea5c40..111ac175e315 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1 +1,2 @@
DIST cacti-1.2.10.tar.gz 24907181 BLAKE2B 7e3e95e531022fb0a49dd951464608860de19e5ab158424ce8daef5b5ac975468f5864acf831b821e83877a17f8310be16f4179afa89bc9d34c4d8d80e9933c4 SHA512 8ed9bd895dc5763fabc20e4fb3c78eb2f520b05fca03b6aac843860402cf15e754af1eb9d65412ed10db6e93531806d1ef48957a08f56f2f8b40f235b4413cf3
+DIST cacti-1.2.11.tar.gz 25099698 BLAKE2B 25d974eb21bafeb9d5c84d1a857b1d95803945c73b21fc4e7219c5349c15aebb4d0130dc9701b3a3615c3514bfa3f3a29286153ba8f7cb515a255e06f20a56a9 SHA512 ab8a856fde55f405314fe0ec1eccccfb78105181fc081dcc04091963b08777550182867b45daea4f630f19dbb538ad7ca5c62f2dac9cd867524dfef113e2a220
diff --git a/net-analyzer/cacti/cacti-1.2.11.ebuild b/net-analyzer/cacti/cacti-1.2.11.ebuild
new file mode 100644
index 000000000000..66775efc3b40
--- /dev/null
+++ b/net-analyzer/cacti/cacti-1.2.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils webapp
+
+# Support for _p* in version.
+MY_P=${P/_p*/}
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="https://www.cacti.net/"
+SRC_URI="https://www.cacti.net/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="snmp doc"
+
+need_httpd
+
+RDEPEND="
+ dev-lang/php[cli,mysql,pdo,session,sockets,xml]
+ dev-php/adodb
+ net-analyzer/rrdtool[graph]
+ virtual/cron
+ snmp? ( >=net-analyzer/net-snmp-5.2.0 )
+"
+
+src_compile() { :; }
+
+src_install() {
+ dodoc CHANGELOG
+ dodoc -r docs
+ mv docs .. || die
+
+ webapp_src_preinst
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${MY_HTDOCSDIR}
+ cp -r . "${D}"${MY_HTDOCSDIR}
+
+ webapp_serverowned ${MY_HTDOCSDIR}/rra
+ webapp_serverowned ${MY_HTDOCSDIR}/log
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}