summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nload
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nload')
-rw-r--r--net-analyzer/nload/Manifest1
-rw-r--r--net-analyzer/nload/files/nload-0.7.4-tinfo.patch10
-rw-r--r--net-analyzer/nload/metadata.xml5
-rw-r--r--net-analyzer/nload/nload-0.7.4.ebuild29
4 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/nload/Manifest b/net-analyzer/nload/Manifest
new file mode 100644
index 000000000000..93f19f60f8b4
--- /dev/null
+++ b/net-analyzer/nload/Manifest
@@ -0,0 +1 @@
+DIST nload-0.7.4.tar.gz 151005 SHA256 c1c051e7155e26243d569be5d99c744d8620e65fa8a7e05efcf84d01d9d469e5 SHA512 ca3e36d3f77c5a7994a3261042fb65a1458a29c769e6bebbe3b8e49b3045aca6f4d047065d11431b28368e0d881c24c92533fa24f0e54ac270f1f5bccfb5c0af WHIRLPOOL 272814facf78f6451caa5d87d157f9002e81eb0420ab0f2a462e1334f5ab105f45bf67e340dfb0e3b327ce2276c2e5f8c40f552a59befa550ee120d7ea8f0982
diff --git a/net-analyzer/nload/files/nload-0.7.4-tinfo.patch b/net-analyzer/nload/files/nload-0.7.4-tinfo.patch
new file mode 100644
index 000000000000..dcab6ec324f4
--- /dev/null
+++ b/net-analyzer/nload/files/nload-0.7.4-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -70,6 +70,7 @@
+ esac
+
+ dnl Checks for libraries.
++PKG_CHECK_MODULES([NCURSES],[ncurses],[LIBS="$LIBS $NCURSES_LIBS"],[AC_MSG_ERROR([ncurses was not found])])
+ AC_CHECK_LIB(ncurses, initscr)
+ AC_CHECK_LIB(form, new_form)
+
diff --git a/net-analyzer/nload/metadata.xml b/net-analyzer/nload/metadata.xml
new file mode 100644
index 000000000000..43ff75467369
--- /dev/null
+++ b/net-analyzer/nload/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/nload/nload-0.7.4.ebuild b/net-analyzer/nload/nload-0.7.4.ebuild
new file mode 100644
index 000000000000..86e8143d10b5
--- /dev/null
+++ b/net-analyzer/nload/nload-0.7.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="console application which monitors network traffic and bandwidth usage in real time"
+HOMEPAGE="http://www.roland-riegel.de/nload/index.html"
+SRC_URI="http://www.roland-riegel.de/nload/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc x86"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ eautoreconf
+}
+
+src_configure() {
+ # --enable-debug means do not strip debugging symbols (default no)
+ econf --enable-debug
+}