summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-02-21 15:10:15 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-02-21 15:11:06 +0100
commita0768da81fc036b52ae85ad42fa02138b2309599 (patch)
treeacc05c52dad2ba2ad2e096c701a60412dcf53b13 /net-analyzer/wapiti/wapiti-3.0.3.ebuild
parentdev-python/yaswfp: add python 3.7 (diff)
downloadgentoo-a0768da81fc036b52ae85ad42fa02138b2309599.tar.gz
gentoo-a0768da81fc036b52ae85ad42fa02138b2309599.tar.bz2
gentoo-a0768da81fc036b52ae85ad42fa02138b2309599.zip
net-analyzer/wapiti: 3.0.3 bump
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-analyzer/wapiti/wapiti-3.0.3.ebuild')
-rw-r--r--net-analyzer/wapiti/wapiti-3.0.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-analyzer/wapiti/wapiti-3.0.3.ebuild b/net-analyzer/wapiti/wapiti-3.0.3.ebuild
new file mode 100644
index 000000000000..a89de4ef3a34
--- /dev/null
+++ b/net-analyzer/wapiti/wapiti-3.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_P=${PN}3-${PV}
+DESCRIPTION="Web-application vulnerability scanner"
+HOMEPAGE="http://wapiti.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kerberos ntlm test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/requests-1.2.3[${PYTHON_USEDEP}]
+ dev-python/tld[${PYTHON_USEDEP}]
+ dev-python/yaswfp[${PYTHON_USEDEP}]
+ kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
+ ntlm? ( dev-python/requests-ntlm[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ sed -e 's/"pytest-runner"//' -i setup.py || die
+ distutils-r1_python_prepare_all
+}