summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-23 13:12:56 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-23 13:15:49 +0200
commit8576e71bef170d86fa3913764aa26253ec947d4b (patch)
tree4ee36e8aca5abe8119d633edc936f0067a375a2c /net-analyzer/wireshark
parentgames-strategy/freeorion: Bumped live ebuild to EAPI-7 (diff)
downloadgentoo-8576e71bef170d86fa3913764aa26253ec947d4b.tar.gz
gentoo-8576e71bef170d86fa3913764aa26253ec947d4b.tar.bz2
gentoo-8576e71bef170d86fa3913764aa26253ec947d4b.zip
net-analyzer/wireshark: Update live ebuild
* EAPI=7 * Add USE=brotli * Add USE=plugins (enabled by default) * Add USE=plugin_ifdemo (disabled by default) * Run cmake-utils_src_test in src_test Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/metadata.xml3
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild26
2 files changed, 18 insertions, 11 deletions
diff --git a/net-analyzer/wireshark/metadata.xml b/net-analyzer/wireshark/metadata.xml
index 268fb2956451..4a20e26519da 100644
--- a/net-analyzer/wireshark/metadata.xml
+++ b/net-analyzer/wireshark/metadata.xml
@@ -30,6 +30,7 @@ be exported to XML, PostScript®, CSV, or plain text.
<flag name="adns">Use <pkg>net-dns/c-ares</pkg> to resolve DNS names</flag>
<flag name="androiddump">Install androiddump, an extcap interface to capture from Android devices</flag>
<flag name="bcg729">Use <pkg>media-libs/bcg729</pkg> for G.729 codec support in RTP Player</flag>
+<flag name="brotli">Use <pkg>app-arch/brotli</pkg> for compression/decompression</flag>
<flag name="capinfos">Install capinfos, to print information about capture files</flag>
<flag name="captype">Install captype, to print the file types of capture files</flag>
<flag name="ciscodump">Install ciscodump, extcap interface to capture from a remote Cisco router</flag>
@@ -44,6 +45,8 @@ be exported to XML, PostScript®, CSV, or plain text.
<flag name="netlink">Use <pkg>dev-libs/libnl</pkg></flag>
<flag name="nghttp2">Use <pkg>net-libs/nghttp2</pkg> for HTTP/2 support</flag>
<flag name="pcap">Use <pkg>net-libs/libpcap</pkg> for network packet capturing (build dumpcap, rawshark)</flag>
+<flag name="plugin_ifdemo">Install plugin interface demo</flag>
+<flag name="plugins">Install plugins</flag>
<flag name="randpkt">Install randpkt, a utility for creating pcap trace files full of random packets</flag>
<flag name="randpktdump">Install randpktdump, an extcap interface to provide access to the random packet generator (randpkt)</flag>
<flag name="reordercap">Install reordercap, to reorder input file by timestamp into output file</flag>
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 1070cd95b0e6..937819a5e035 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{5,6,7} )
-inherit cmake-utils fcaps flag-o-matic git-r3 ltprune multilib python-r1 qmake-utils user xdg-utils
+inherit fcaps flag-o-matic git-r3 multilib python-r1 qmake-utils user xdg-utils cmake-utils
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
HOMEPAGE="https://www.wireshark.org/"
@@ -13,11 +13,11 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="
- adns androiddump bcg729 +capinfos +captype ciscodump +dftest doc dpauxmon
- +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap +netlink
- nghttp2 +pcap +qt5 +randpkt +randpktdump +reordercap sbc selinux +sharkd
- smi snappy spandsp sshdump ssl sdjournal +text2pcap tfshark +tshark
- +udpdump zlib
+ adns androiddump bcg729 brotli +capinfos +captype ciscodump +dftest doc
+ dpauxmon +dumpcap +editcap kerberos libxml2 lua lz4 maxminddb +mergecap
+ +netlink nghttp2 +plugins plugin_ifdemo +pcap +qt5 +randpkt +randpktdump
+ +reordercap sbc selinux +sharkd smi snappy spandsp sshdump ssl sdjournal
+ +text2pcap tfshark +tshark +udpdump zlib
"
S=${WORKDIR}/${P/_/}
@@ -27,6 +27,7 @@ CDEPEND="
dev-libs/libgcrypt:0
adns? ( >=net-dns/c-ares-1.5 )
bcg729? ( media-libs/bcg729 )
+ brotli? ( app-arch/brotli )
ciscodump? ( >=net-libs/libssh-0.6 )
filecaps? ( sys-libs/libcap )
kerberos? ( virtual/krb5 )
@@ -59,6 +60,8 @@ CDEPEND="
DEPEND="
${CDEPEND}
${PYTHON_DEPS}
+"
+BDEPEND="
!<perl-core/Pod-Simple-3.170
!<virtual/perl-Pod-Simple-3.170
dev-lang/perl
@@ -80,6 +83,7 @@ RDEPEND="
"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
+ plugin_ifdemo? ( plugins )
"
PATCHES=(
"${FILESDIR}"/${PN}-2.4-androiddump.patch
@@ -147,6 +151,7 @@ src_configure() {
-DCMAKE_INSTALL_DOCDIR="/usr/share/doc/${PF}"
-DDISABLE_WERROR=yes
-DENABLE_BCG729=$(usex bcg729)
+ -DENABLE_BROTLI=$(usex brotli)
-DENABLE_CAP=$(usex filecaps caps)
-DENABLE_CARES=$(usex adns)
-DENABLE_GNUTLS=$(usex ssl)
@@ -157,6 +162,8 @@ src_configure() {
-DENABLE_NETLINK=$(usex netlink)
-DENABLE_NGHTTP2=$(usex nghttp2)
-DENABLE_PCAP=$(usex pcap)
+ -DENABLE_PLUGINS=$(usex plugins)
+ -DENABLE_PLUGIN_IFDEMO=$(usex plugin_ifdemo)
-DENABLE_SBC=$(usex sbc)
-DENABLE_SMI=$(usex smi)
-DENABLE_SNAPPY=$(usex snappy)
@@ -168,8 +175,7 @@ src_configure() {
}
src_test() {
- emake -C "${BUILD_DIR}" test-programs
- emake -C "${BUILD_DIR}" test
+ cmake-utils_src_test
}
src_install() {
@@ -215,8 +221,6 @@ src_install() {
newins image/WiresharkDoc-${s}.png application-vnd.tcpdump.pcap.png
done
fi
-
- prune_libtool_files
}
pkg_postinst() {